Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   Communications and Electronics (http://www.wranglerforum.com/f40/)
-   -   amp caught fire this morning (http://www.wranglerforum.com/f40/amp-caught-fire-this-morning-229079.html)

_plaisance 03-20-2013 01:08 PM

amp caught fire this morning
 
Anybody could give any info on why or how it caught fire bad amp?? I been running it for over a year 1200 rms ma audio pushing two kicker cvr 12

Jma20a 03-20-2013 03:59 PM

faulty fuse, ohm load too low(sub at a lower ohm than the amp can support), bad ground, over powering the amp(how did you set the gain on the amp? or did you have it installed at a shop?)

sparky 03-20-2013 04:50 PM

No air flow to cool it. Where was it mounted.
One of the outputs shorted.

_plaisance 03-22-2013 12:46 PM

1 Attachment(s)
My amp gain was about 3/4 it wasn't overpowered kickera ran 800 rms amp was 1200 rms true watts

Attachment 226011

Jma20a 03-22-2013 02:24 PM

Are u sure it isnt 1200 max and 800 rms. not sure what u mean by "true watts"

Jma20a 03-22-2013 02:39 PM

You cant gauge how much power u are sending by how far the gain knob is set. The only way to know is to break out a calculator, a digital multi-meter and a test tone.

Jerry Bransford 03-22-2013 03:39 PM

The amp should not have caught on fire no matter how many watts it was pumping out or what its load was at the speakers, basic sound electrical engineering design principles prevent that. I'd guess inadequate air circulation around it like from being mounted in a confined space, an amplifier design flaw, or a component failure.

coastalwrangler 03-22-2013 04:50 PM

Quote:

Originally Posted by Jerry Bransford (Post 3539219)
The amp should not have caught on fire no matter how many watts it was pumping out or what its load was at the speakers, basic sound electrical engineering design principles prevent that. I'd guess inadequate air circulation around it like from being mounted in a confined space, an amplifier design flaw, or a component failure.

2x

How long were you listening to it before it caught fire? If not very long I'd guess a design failure.

Kssun 03-24-2013 08:20 AM

What music were you playing? If Jimi was tearing it up on a wicked solo, I'm not sure that's covered under any electrical engineering guidelines. (Couldn't resist). Sorry about your amp.

Tiburon 03-26-2013 01:25 PM

You do have it fused correct? The fuse should have blown waaaay before a fire started. Also did it have a good ground? Any loose connection will cause a choke point for the flow of power and choke points get hot.


All times are GMT -5. The time now is 04:03 AM.