Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ Tech Forum (http://www.wranglerforum.com/f210/)
-   -   Help !!! (http://www.wranglerforum.com/f210/help-230096.html)

Klong 03-24-2013 10:24 PM

Help !!!
 
I recently bought a 2001 wrangler TJ 4.0 I have wanted a jeep all my life and now I have it and love her. I am still learning the ropes when it comes to maintenance and such. I recently started noticing a reoccurring issue. lets say I drive for 30 minutes and then turn the engine off. When I restart the motor spits, spudders and barely runs for about 20 -30 seconds and then starts running fine. Now some new symptoms to go along with this. This morning I drove to work and shut her off. I went to restart immediately and she would crank but not start at all. I let her sit for about 30 minutes and then she restarted. I have three codes with a check engine light. P0171, P0174, P0456. If I have correctly done my homework, two of these codes deal with fuel/air mixture being to lean and overcompensation. the third code P0456 is a small leak detected in the evaporative system. Can anyone shed some light on where I might begin to fix my issues or if they are related? Thanks for any help you can lend.

SeVeReDiStOrTiOn 03-24-2013 10:37 PM

Yea those are lean codes for both banks. Rent a fuel pressure tester and see what's going on...i'm thinking fuel pump. The other code could be a bad gas cap.

Klong 03-25-2013 07:40 PM

yes!!!!!
 
You were right on the money. I stopped at my bank and she layed down. I couldn't restart it. Managed to get it to the garage. Dropped the tank and opted to replace whole fuel pump assembly for $60.00 more than the pump alone. Running great...Yes!!!!!! Thanks....


All times are GMT -5. The time now is 07:42 AM.