Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ Tech Forum (http://www.wranglerforum.com/f210/)
-   -   Horn Not Working (http://www.wranglerforum.com/f210/horn-not-working-230438.html)

99wrangler99 03-26-2013 10:07 AM

Horn Not Working
 
Hey guys, so my 1999 tj horn is not working I tested the plug to the horn and got nothing... I have replaced the relay and still no luck, I don't think it's the clock spring because the airbag light is not on. Is there an actual fuse behind the glove compartment or in the box under the hood? The manual doesn't really give any help on locating it if there is one? Any help would be great!

tangofox007 03-26-2013 11:12 AM

Per the '99 FSM, fuse #17 in the PDC (engine compartment.)

http://www.jeep4x4center.com/knowled...ex.htm#service

1ofakind 03-26-2013 12:06 PM

Well I have the same problem. Its the clock spring... airbag light is on and no horn.

Ooops read that wrong...

99wrangler99 03-26-2013 06:15 PM

Maybe a bad ground in my steering wheel assembly? I don't really want to tear down the steering wheel, any suggested tests? Btw I looked for that fuse 17 it's not labeled on the back of my pdc cover, what page did you find it on in that website? @ tangofox007

RUBI 4 MY MRS 03-26-2013 07:44 PM

After selecting TJ & ’99 go to the last section of the dropdown to Wiring Diagrams. After it loads you need page 2 of the Power Distribution section (about page 22 of 236 in the flash display). Page 36/236 shows the relay. The whole circuit is page 101/236 (8W-41-3).

Start by putting 12v directly to the horns from the battery. It they work (& the 17 fuse is good) you can ground the RD/YL wire either at the relay or the clockspring connector (that should click the relay & work the horn). If that works (but no horn when pushing the horn button) then the clockspring, horn switch (part of the airbag cover) is bad or the column is not grounded (not likely).


All times are GMT -5. The time now is 09:02 AM.