Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ Tech Forum (http://www.wranglerforum.com/f210/)
-   -   Oil Pressure (http://www.wranglerforum.com/f210/oil-pressure-2313.html)

eprovenzano 07-18-2006 02:59 PM

Oil Pressure
 
My son's 97 SE 2.5 has no oil pressure when idling. When you give it a little gas, its climbs as you would expect. Driving down the road, its at 40lbs. Other than idling its seems fine. I changed the oil pressure sending unit, no change in oil pressure. I changed the oil pump, no change. Could the gauge be the problem. At this point I'm out of ideas... :confused:

whitebuffalo 07-18-2006 03:08 PM

hook up a mechanical gauge and see what it reads. thatll rule out gauge/sender/electrical failure.

LIL_red_JEEP 07-19-2006 10:10 AM

hi, not sure how little pressure you're referring to at idle or as "no pressure" at all. but here is factory specs for that vehicle:
OIL PUMP PRESSURE


MINIMUM at 600 rpm 89.6 kPa (13 psi)

At Idle Speed 800 rpm 172 - 241 kPa (25 - 35 psi)

MAXIMUM at 1600 rpm or more 255 - 517 kPa (37 - 75 psi)

Hooking up a mechanical gauge would be your best bet. good advice

eprovenzano 07-19-2006 01:11 PM

At idle, I have zero oil pressure... Even with a few miles under its belt, it should be 15-30 at idle, and 40 - 70 going down the road. Thanks for the tip, I plan on trying a mech pump. I hope to get to that this weekend.

I think there is oil pressure and the gauge is not reading the correct pressure, but I need to be sure.

whitebuffalo 07-19-2006 01:45 PM

most DC oil pressure gauges are just glorified idiot lights. if its getting pressure between 3-50 psi, it reads the same. get u a mechanical gauge, thatll tell u without a doubt wats going on


All times are GMT -5. The time now is 05:29 PM.