Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   YJ Tech Forum (http://www.wranglerforum.com/f218/)
-   -   engine temp issue (http://www.wranglerforum.com/f218/engine-temp-issue-233879.html)

Dillon84 04-08-2013 07:34 PM

engine temp issue
 
hey everyone this is a new one on me, i was sitting in the old girl letting her idle for a bout 10 minutes whe i noticed my temp gage past red line but no noticeable affects. naturally i freak and shut her down but when i fired back up the needle marched back to red line so i tried to start for home. well as soon as i was moving she dropped back down below half way and as long as i was moving thats where it stayed till i stopped or slowed way down, when i did she started climbing again. what is it? please help?

Defcon 1 04-08-2013 08:17 PM

The thermostat is suspect. It's possible it's not opening under low engine idle speeds/pressures. When you're moving the airflow helps keep the engine cooler too, but start with the T-stat they're real cheap and easy to R&R.

Other possible causes could be inadequate coolant/reservoir level, (also easy to correct), fan clutch lock-up, water-pump lock up.

-Do Not- let the temperature get redline under any circumstances, if it goes about 230 again it didn't fix it, shut it down immediately. Even the slightest amount of over-temp can wear the engine components out.

Dillon84 04-08-2013 08:23 PM

ok i was thinking that but wasn't sure seeing ive never had a stat do that to me before


All times are GMT -5. The time now is 04:23 PM.