Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   JK General Discussion Forum (http://www.wranglerforum.com/f274/)
-   -   HELP!! Electrical probs!! (http://www.wranglerforum.com/f274/help-electrical-probs-234612.html)

liner9er 04-11-2013 01:37 PM

HELP!! Electrical probs!!
 
Has anyone had any electrical problems with their '07? My radio keeps cutting in and out and just 2 days ago, my seatbelt light comes on and dings when I step on the brake pedal. WTH is going on? I know NOTHING about electrical issues!! Please... my warranty ran out in December.:banghead:

sevenservices 04-11-2013 01:41 PM

Did any water get in anywhere behind the dash?

also, make sure your battery connections are clean and tight.

Aside from those, I'll let some TJ guys chime in!

and Welcome to the forum!

liner9er 04-11-2013 01:46 PM

No water that I am aware of... I'll double check battery connections. Thanks.

rirrgang 04-11-2013 04:52 PM

Check all grounds. There are few under the dash and under the hood. There may be a couple under the seats. Check the door connections. Everything runs in CANBUS. If something isn't right somewhere, other items will start to have problems.
It may be worth to have a reputable shop run a scan on the JK. It will tell him a lot of interesting stuff. I don't mean a scan for obcdII codes. A scan with a scan tool is what I'm suggesting.

ModernProspector 04-11-2013 04:54 PM

Sounds like a body ground wire broke. Look for a broken wire from the negative battery terminal to the body sheet metal, or a braided wire strap from the engine or tranny to the body. Pull/twist on the ends to make sure the connections are tight.

Loss of the chassis ground can do all sorts of weird things electrically due to alternate ground paths through other things (like drivetrain gears and splines in some cases).


All times are GMT -5. The time now is 10:04 AM.