Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   YJ Tech Forum (http://www.wranglerforum.com/f218/)
-   -   So i gots the death wabble.... (http://www.wranglerforum.com/f218/so-i-gots-the-death-wabble-234926.html)

Square_Eyes 04-12-2013 09:40 PM

So i gots the death wabble....
 
Ok specs:

95 wrangler 4.0 5 speed
Ford D44 front
Ford 9" rear

I just swapped these axles in about 650 miles ago and i started to get death wobble. It only happens after i hit a bump so i started looking for stuff that was loose on the front end. Steering box had play and one of my new ball joints had play, replaced both of those and everything feels tight now! Still getting death wobble but only if i hit a really big bump...not sure exactly what it could be at this point. Im running reid racing knuckles and full high steer set up, everything under the front end is new too.

Norcal_Chris 04-12-2013 11:27 PM

What is your caster?
Steering stabilizer?
Are tires weight balanced or bb balanced? How recent? Tryed swapping?
What is your toe set at?
How long are your front shackles? Do you have a shackle reversal?

Square_Eyes 04-13-2013 12:14 AM

Caster is at 0 pinion at 7 or 8
No stabilizer
Weight balanced, 650 miles ago
Havent tried swapping yet
Toe is set at 1/8 toe in
Stock shackles, no reversal
Forgot to mention that its soa

Norcal_Chris 04-13-2013 07:46 AM

Quote:

Originally Posted by Square_Eyes (Post 3630401)
Caster is at 0 pinion at 7 or 8
No stabilizer
Weight balanced, 650 miles ago
Havent tried swapping yet
Toe is set at 1/8 toe in
Stock shackles, no reversal
Forgot to mention that its soa

Your caster should be between 4 and 6 positive at the knuckles. Too little and it will not return to center and can wobble pretty bad.

A stabilizer may cure the big bump wobble issue. I have one on because of worn components and it keeps my wobble in check. Before, without a stabilizer a big bump would start the oscillation. But the stabilizer keeps the initial hit from escalating, so its a bandaid fix, but it works.

Square_Eyes 04-13-2013 11:50 AM

I set it up the exact same that my D30 was set at and never had the DW with that, i dont really have a place to mount a stabilzer but i could prolly fab something up pretty quick, my caster is way off too \---o--/ thats what my tires look like right now, not sure if that would cause it or not


All times are GMT -5. The time now is 01:30 AM.