Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   General Jeep Discussion (http://www.wranglerforum.com/f19/)
-   -   Rust already under new Rubicon (http://www.wranglerforum.com/f19/rust-already-under-new-rubicon-236116.html)

TonyLent 04-18-2013 12:04 PM

Rust already under new Rubicon
 
Hi,

I am new to WranglerForum.com, this is my first post...

In January I bought a 2013 Rubicon. It now has 2200 miles on it. I brought it in for the first oil change today.

I noticed under the front end there is already rust forming. My Jeep dealer said this was normal and even if I had the undercoating done it still would get rusty underneath.

BTW: This is a garage-kept vehicle.

Has anyone had a similar experience? Would you agree that this is normal and nothing needs to be done about it?

Any advice would be appreciated.

Thanks,
Tony Lent...

CorvusCorax 04-18-2013 12:51 PM

There are 3 or 4 threads on this "normal" problem in the JK tech forum...with the amount of people this is happening to,it looks like it might be normal for 2013s.

Rude Dog 04-18-2013 12:53 PM

Rust where? Certain components are not painted from the factory. If its a painted part, push back on the dealer to see if they will do anything. In Calif don't really see that type issue, so no dealer experience on rust. What does the warranty cover? In the end if they don't help, I'd crawl under it, scrape, wire brush, prep and paint everything now while its new and rust hasn't really taken hold much, or gone crazy. It will be far worse to go back and do later.

1jeeplvr 04-18-2013 08:09 PM

I guess it depends on the components.id expect that on an exhaust.

J33P4M3 04-19-2013 09:35 PM

vehicles kept in garages often times rust more than those outside due to lack of air circulation when you drive a wet vehicle in a garage and close the door. Just sits there in all that warm, humidity.

kjeeper10 04-20-2013 04:34 AM

Quote:

Originally Posted by CorvusCorax (Post 3652665)
There are 3 or 4 threads on this "normal" problem in the JK tech forum...with the amount of people this is happening to,it looks like it might be normal for 2013s.

This ^

Surface rust is normal. The driveshafts seem to show first.

TonyLent 04-22-2013 06:05 AM

Thanks - I never realized that.

TonyLent 04-22-2013 06:06 AM

Thanks - I took a look.

I think the pics posted there are a lot worse than mine. I will have to fully get underneath the vehicle to be certain.


All times are GMT -5. The time now is 08:42 PM.