Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   YJ Tech Forum (http://www.wranglerforum.com/f218/)
-   -   blower motor problems!! (http://www.wranglerforum.com/f218/blower-motor-problems-23619.html)

atlsouthpaw 12-01-2008 08:57 AM

blower motor problems!!
 
I have a 1995 jeep wrangler. The blower motor is not working. I can feel heat, just not blowing. The fuse was blown, so I replaced it. It blew again. I disconnected the heater switch from the blower...and the fuse STILL blew! Does anyone know if the motor is bad or is it the switch, or something else entirely? Thanks.:)

Coyote_94YJ 12-01-2008 01:23 PM

Sounds like you have a wire shorted to ground somewhere. If you disconnect the switch and the fuse still blows, that would rule out the switch. You said the fuse blew with the motor disconnected so that means its not the motor. Dunno. I would start tracing wires looking for bare wire touching metal or something like that.

87YJWrangler 12-01-2008 05:47 PM

I know my fan is full of crap and natural debris like leafs and shit, is there anyway to remove the gaurds so I can clean them out????:banghead:

Jeep_Geek 12-01-2008 06:00 PM

Just had the same problem.. I traced it to the wire from the fuse box to the switch.. there was a short somewhere in it but it goes up in a harness so I just ran a new wire to the switch. works great now.

atlsouthpaw 12-01-2008 07:15 PM

Thanks dude!!!! That was exactly the problem! :)


All times are GMT -5. The time now is 10:43 PM.