Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   YJ Tech Forum (http://www.wranglerforum.com/f218/)
-   -   Connected battery wrong (http://www.wranglerforum.com/f218/connected-battery-wrong-236834.html)

theYeti 04-21-2013 07:42 PM

Connected battery wrong
 
Was putting on new fenders and when reconnecting the battery I had the battery turned around from previous position, didn't pay attention and connected it wrong like a dumbass. Now the voltage meter is reading low and my radio doesn't work. Does anyone know what I did? I figured something like that would result but didn't expect the radio to be gone. Did I screw my alternator?

goin camping 04-21-2013 08:03 PM

Been there and done that. :D

Check your fuses and I'll bet you'll find a couple of fried ones. That should be the only damage.

jk'n 04-21-2013 08:25 PM

If the radio still doesn't work after replacing fuses, there is generally a diode across the incoming line for just this occasion to protect the radio components. That diode will conduct heavily on reverse polarity usually taking out the fuse before shorting the diode. If however you power up the radio and it takes out the new fuse, you will likely have to replace the diode.

theYeti 04-21-2013 09:33 PM

What's a dido? I've never dealt with electrical problems lol

jk'n 04-21-2013 10:53 PM

If you don't know what a diode is then my advice would be to have it looked at by a technician. Isn't worth having it serviced? Get a new one.

theYeti 04-22-2013 10:58 AM

Will do, hopefully it's not that though


All times are GMT -5. The time now is 03:47 PM.