Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   CJ Build Forum (http://www.wranglerforum.com/f338/)
-   -   76 CJ-5 build (http://www.wranglerforum.com/f338/76-cj-5-build-236921.html)

NHflannelman12JK76CJ5 04-22-2013 07:07 AM

76 CJ-5 build
 
howdy - been chiming in from time to time on threads but figured it was due time to update anyone who is interested in what's going on.

My dad and I bought a 1976 CJ-5 with a 304 V8. We bought it from a guy who had picked it up from an old-timer who was using it to plow his driveway - problem here was that the old guy couldn't see and backed up into everything. The rear corners are pretty messed up with dents, holes and rust. Yum. Also, there's no tailgate - just a flat panel (makes me wonder if there's a military tub on it? or maybe that was an option back in the day - experts, feel free to chime in).

There's quite a bit of rust on this - not a cosmetic girl by any means. But she's got the Dana 30 front and the AMC 20 rear. My thought was that this should have been a three speed, that's what we were told, but when I run through the gears there are most certainly 5 gears there - so I'm wondering how much the 'middle man' actually knew about the Jeep.

Interestingly, he (seller) said he had it running this past fall. He couldn't get it to start when he sold it to us. We were able to get it running a few weeks ago with starter fluid.

Some may recall, and I got great help on this (thank you), that there was a fuel line issue. Well, we got this straightened out and replaced the fuel pump (intake spigot was broken off) and this is where we found out that the fuel line wasn't going up to the fuel pump. This makes me doubt that the seller had it running and driving.

Anyways, we'll need to blow the fuel line after we unplug it from the tank but this might be a few weeks down the road as I have a Bachelor party to go to next weekend.

We've also run into an electrical issue. We put a new battery in it and three weeks later it was drained. Alternator looks fairly new and I don't think we have a short. So we'll need to get to the bottom of this.

I'll post pics once I figure out how to do so.

Cheers,

Trav

lynn 04-22-2013 07:55 AM

Some factory tubs had no tailgate. "Renegade" trim, IIRC, was the mid-70s CJ5 without a factory tailgate.

The factory 304 V8 was backed exclusively by a T15 three-speed in 1976.
If you have any other tranny, it was swapped-in.

semophil 05-07-2013 03:00 PM

Trav, by any chance would you have an additional bearing retainer for the T15 3 speed transmission for that CJ you purchased?

Phil

NHflannelman12JK76CJ5 05-27-2013 05:46 PM

Quote:

Originally Posted by semophil (Post 3729975)
Trav, by any chance would you have an additional bearing retainer for the T15 3 speed transmission for that CJ you purchased?

Phil

Hi Phil - sorry my friend I do not. I wish you luck with your find. Cheers, Trav

Quote:

Originally Posted by lynn (Post 3667471)
Some factory tubs had no tailgate. "Renegade" trim, IIRC, was the mid-70s CJ5 without a factory tailgate.

The factory 304 V8 was backed exclusively by a T15 three-speed in 1976.
If you have any other tranny, it was swapped-in.

It's a 5 speed. Haven't crawled under to see if I can find anything but I've gone through it and unless there are some phantom gears, I'm rockin' a 5 speed. Lynn - always appreciate your jeep knowledge in this and other threads - always good stuff to know.

Nothing big on the update front: replaced the solenoid and ripped out the back seat. Have also discovered that the 'blue' paint job wasn't put on properly (not sanded) over the original sky blue color - stuff just keeps flaking off. Oh well, it ain't a bute.

Will get there with this one - long term project. Need the carb cleaned (motorcraft) and need to drain the tank and fix the fuel line. With any luck, I'll be able to at least drive it around the yard.

Pictures soon. Nothing to write home about. Thanks for reading.

Dustdevil 07-19-2014 12:14 AM

I owned a 1975 just like yours. Renegade with solid body, no tailgate. 304 V8, and rock crusher 3-speed with no synchro in first gear. The clutch linkage was a problem with those, especially when the motor mounts started to get spongy. Shackle lift in front, and it would climb a wall. Sold it in 1982 for a song to a guy who claimed he was going to race it. Bad idea, even then. But hey, I was no longer the owner.


All times are GMT -5. The time now is 07:41 AM.