Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ Tech Forum (http://www.wranglerforum.com/f210/)
-   -   Bad Flasher Cluster? I hope? (http://www.wranglerforum.com/f210/bad-flasher-cluster-i-hope-237307.html)

Bet 04-23-2013 07:13 PM

Bad Flasher Cluster? I hope?
 
Just picked up my '00 TJ few days ago and I'm having some electrical issues.

I think it's the flasher cluster because when I first got it, I jiggled it and the stereo headunit got power, my wipers worked, and my flashers started to work again - doing a temp. fix I wire tied the cluster and the plug together but I'm still having the issue.

So - do you guys think it is the flasher cluster or another wire I was jiggling while messing around under the steering column?

nicodemus 04-23-2013 07:18 PM

What exactly are you seeing when it is not working?

Bet 04-23-2013 07:25 PM

Quote:

Originally Posted by nicodemus (Post 3674383)
What exactly are you seeing when it is not working?

No blinkers, stereo, or wipers - also when none of them are working and you hit the blinker, while you have the brake on the light that is supposed to be blinking just stays unlit and the others light up because of the brakes.

Right now all I do is turn the Jeep on and off again until everything works, then go.

nicodemus 04-23-2013 07:54 PM

That definitely sounds messed up. Multiple things not working makes me think it may be a grounding issue. But there could be a number of other things wrong with it.

I had a similar issue with a gmc jimmy I had a few years back and it turned out that a ground wire had come loose / broke. I'm not sure if that will help you in this case though. Maybe a more mechanically inclined person can lend some insight.

Sorry I can't be more help : /

RUBI 4 MY MRS 04-23-2013 10:25 PM

Those are on fuses that are all powered by the same contacts in the ignition switch. Fuses 13,14&15. Sooner or later they will quit completely, replace the ignition switch. There is a u-tube video by Dorman on replacing the ignition actuator pin but the ignition switch is removed as part of that fix.

It is actually normal for the brake lights to act that way when the signals aren’t working. Fix the switch & everything should be good.


All times are GMT -5. The time now is 10:17 AM.