Jeep Wrangler Forum

Jeep Wrangler Forum (
-   TJ Tech Forum (
-   -   Engine idle surge while shifting. (

nickastaldo 07-24-2006 11:01 AM

Engine idle surge while shifting.
I have an 04 Rubicon with a manual transmission and the 4.0.

Since I first got it a year and a half ago, it has had an annoying problem. When coasting with it in gear, as in slowing down for a light to change etc., the Jeep will continue to drive like it's in Cruise for a second, and then it has a hard jerk as it starts to slow down. Also while shifting, the engine speed has a little power surge, there is a little jolt as the engine speed goes up by 100 to 200 RPM for a second or two and SLOWLY comes back down. Is this common? It's funny, because it does this most of the time, but occasionally the Jeep drives awesome... like every other Jeep I've driven. Any info on this, or does this sound kind of rare?

Thanks for anything given.


JeepCrawler98 07-24-2006 11:35 AM

At what RPM is this? I'd check the throttle position sensor and idle air controller (if it's around less than like 1500rpm), also check for vacuum leaks, and give a visual inspection of the mechanics of the throttle body.

nickastaldo 07-24-2006 11:37 AM

Actually, it's at pretty much all RPMs. I mean, if I get on the throttle a little bit, and rasie it to say 3500rmps, and then as I put in the clutch to shift, the engine will raise to about 3700rpms... this actually leads to a slopy shift. It's kind of hard to explain, so hopefully this makes sense.

JeepCrawler98 07-24-2006 12:00 PM

And you're letting off the gas as you shift I assume? So basically it's running at 3700rpms with the foot off the gas depending on what the initial engine speed was before you shifted? If that's the case I'd check the butterfly valve in the throttle body, the throttle return spring, or the throttle cable itself, it may be sticking.

nickastaldo 07-24-2006 12:13 PM

I'll scope that out when I have a chance.. should I just shoot some TB cleaner in there?

JeepCrawler98 07-24-2006 12:14 PM

If it's dirty - sure couldn't hurt.

Vector6 07-24-2006 02:51 PM

A guy in my jeep club has an 05 rubi with an auto that does the exact same thing.. the dealer hasnt been able to pinpoint the problem... they keep telling him "Theres nothing wrong with it that we can find"

I just thought it happened because his is an auto..

All times are GMT -5. The time now is 04:20 AM.

User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.