Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   JK General Discussion Forum (http://www.wranglerforum.com/f274/)
-   -   Anyone running a chr 550 lockpick? (http://www.wranglerforum.com/f274/anyone-running-a-chr-550-lockpick-237531.html)

cheap4tw 04-24-2013 04:26 PM

Anyone running a chr 550 lockpick?
 
I just ordered this today as it came back in stock at sonicelectronics. I was curious if anyone has mounted one in a 2012 in the described location (behind glovebox)?

kyvtx1300 04-24-2013 04:37 PM

Yes, works great with my 430. So far I have wired front and rear cameras. I angled the front way down so I can see better crawling over blind hills. Of course it will most likely be covered in mud when I need it, but it is still cool.

fan4524 05-03-2013 07:22 PM

I bought the CHR550 when I got my 2013 JKU last September. Installed it and it works great. I never could get the rear camera to work properly and finally gave up until recently. I didn't like the mounting options for their camera anyway. Recently I found a post on here with pictures of a flush mount number camera that looked great (search the board for lockpick camera pictures I think). I ordered it and tried the install again this past weekend. I wound up having to call Coastal's tech support b/c the rear camera worked great EXCEPT for when I put vehicle in reverse. Carlos walked me through a fix because from late 2012 and on the wiring harness was modified by Jeep. A quick 10 minute fix (plus 15-20 for dash removal) and everything works great. The only minor problem is that when you make this fix you lose the rear camera when driving option (not a big deal for me but I know some will hate that).

Everything else is a no brainer. Best investment ever. The install is very easy. It takes more time to take the dash off than to plug the unit in. The GPS programming while moving makes all the difference in the world. In motion video I don't really use but nice to have and it works great if you want to use it. I only have the one camera.

Total install time for everything was probably about an hour and a half or so including running the wires. I was hesitant of the dash removal but I have done it several times now and it is a piece of cake.

I highly recommend the unit but wish all of the promised options worked right out of the box.

ericksep 05-05-2013 08:00 PM

Do you have pictures of the fix. I tried to make mine work on reverse but not luck. I saw couples of pictures from another sites but I don't now what I am doing wrong. Camera only work fine on manual mode

Quote:

Originally Posted by fan4524 (Post 3716552)
I bought the CHR550 when I got my 2013 JKU last September. Installed it and it works great. I never could get the rear camera to work properly and finally gave up until recently. I didn't like the mounting options for their camera anyway. Recently I found a post on here with pictures of a flush mount number camera that looked great (search the board for lockpick camera pictures I think). I ordered it and tried the install again this past weekend. I wound up having to call Coastal's tech support b/c the rear camera worked great EXCEPT for when I put vehicle in reverse. Carlos walked me through a fix because from late 2012 and on the wiring harness was modified by Jeep. A quick 10 minute fix (plus 15-20 for dash removal) and everything works great. The only minor problem is that when you make this fix you lose the rear camera when driving option (not a big deal for me but I know some will hate that).

Everything else is a no brainer. Best investment ever. The install is very easy. It takes more time to take the dash off than to plug the unit in. The GPS programming while moving makes all the difference in the world. In motion video I don't really use but nice to have and it works great if you want to use it. I only have the one camera.

Total install time for everything was probably about an hour and a half or so including running the wires. I was hesitant of the dash removal but I have done it several times now and it is a piece of cake.

I highly recommend the unit but wish all of the promised options worked right out of the box.


fan4524 05-06-2013 01:19 AM

Quote:

Originally Posted by ericksep (Post 3722946)
Do you have pictures of the fix. I tried to make mine work on reverse but not luck. I saw couples of pictures from another sites but I don't now what I am doing wrong. Camera only work fine on manual mode


Sorry. No pics. I didn't take notes either but the fix was pretty easy. I just don't remember which two wires had to be spliced. Carlos at Coastal said they get these calls a lot so a quick call there and he can tell you. Have a spare female RCA plug available as well as the whole wiring harness out of the dash when you call so you can see what he is talking about. I was literally on the phone with him for 3-4 minutes.

kyvtx1300 05-07-2013 10:46 AM

I ran the hot wire for the rear camera to the lockpick Rear Camera hot wire and did not use the Reverse Light at all. No problems.

fan4524 05-07-2013 11:44 AM

Quote:

Originally Posted by kyvtx1300 (Post 3729146)
i ran the hot wire for the rear camera to the lockpick rear camera hot wire and did not use the reverse light at all. No problems.

+1

LIGX 05-12-2013 06:17 PM

I just joined the Jeep family (a week ago) and did some research about the lockpick 550. Seems opinions differ significantly about their reliability. I have one sitting in a box ready to be installed. I see some of you have installed these a bit ago.....are the still working reliably.... I'd love to know Thanks in advance


All times are GMT -5. The time now is 11:43 AM.