Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ Tech Forum (http://www.wranglerforum.com/f210/)
-   -   Pigs in my window channels?? (http://www.wranglerforum.com/f210/pigs-in-my-window-channels-237707.html)

Timberline 04-25-2013 11:33 AM

Pigs in my window channels??
 
Looking to see if others experience this with their full doors. Seems that in certain temperatures when I roll down the window, it begins to make this loud squealing sound about halfway down. It makes the noise from rolling halfway to all the way down. Only does it rolling them down and it almost sounds like it is right there in the channel where the seals meet the glass at the base of the window. Mainly in colder weather is when I notice this. Anyone else get this or have a fix for it? :)

Kota7x 04-25-2013 11:43 AM

Are your windows dirty or have water buildup on them? That is only when I notice this. Just takes a wet cloth and they are back to sliding smooth.

Timberline 04-25-2013 11:47 AM

Quote:

Originally Posted by Kota7x (Post 3681492)
Are your windows dirty or have water buildup on them? That is only when I notice this. Just takes a wet cloth and they are back to sliding smooth.

They have a little dirt on them, so I'll clean both inside and out to see if that helps any. They are dry when this occurs. Thanks for the advice.

Mr Mac 04-25-2013 11:49 AM

Mine are nice and quiet! When the window was broken by the tornado we lubed the regulators while we had access.

jeepinmike 04-25-2013 11:50 AM

Clean the window tracks then lubricate with dry white lithium lube (regular white lithium if you can't find dry). That should do it, unless the track are out of adjustment...

SHADYDC 04-25-2013 12:51 PM

mine does make sond some but the problem i have is when window is completely down. the 1st turn on the handle is almost impossible, but hten rest of hte way is normal. ive had panel off and looked around but didnt see anything noticable. i lubed a few spots but didnt work

Timberline 04-25-2013 01:20 PM

I've got some basic ideas now on where to start so I'll see if anything helps before having to rip into the actual panel.

jgorm 04-25-2013 03:02 PM

Mine does the same thing. Seemingly randomly and not based on temps.

lynn 04-25-2013 03:07 PM

The rubber wiper on the inside of mine was catching.
I cleaned the glass inside and out with a good glass cleaner... Then I applied rain-X inside and out, serves as a polish. Finally I applied a small amount of talcum powder to the rubber wiper.

Problem solved.

Timberline 04-25-2013 03:16 PM

Quote:

Originally Posted by lynn (Post 3682198)
The rubber wiper on the inside of mine was catching.
I cleaned the glass inside and out with a good glass cleaner... Then I applied rain-X inside and out, serves as a polish. Finally I applied a small amount of talcum powder to the rubber wiper.

Problem solved.


^^ Now that sounds like a solution!! :)

my98tj 04-26-2013 03:44 PM

the rubber wiper on the inside has "felt" on it and has probably worn off. my grand cherokee does the same thing and sometimes it will actually start to pull the rubber guide into the door.


All times are GMT -5. The time now is 02:01 AM.