Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   YJ Tech Forum (http://www.wranglerforum.com/f218/)
-   -   87 YJ - engine wouldn't turn off when turned key to off position (http://www.wranglerforum.com/f218/87-yj-engine-wouldnt-turn-off-when-turned-key-to-off-position-238317.html)

britt71 04-28-2013 02:38 PM

87 YJ - engine wouldn't turn off when turned key to off position
 
My 87 YJ is confused. I turned the key/ignition off but the motor kept running (even removed the key). The only way to turn it off was to stall. Any ideas? Here are some things I've noticed:

- With the key removed, the radio didn't work but the parking brake light would be on if the parking brake was depressed.

- A day or so later, the batter was dead.

- Charged the battery; when hooked it back up, the starter engaged (key was not even in ignition)

- Now when hooking up the negative terminal to the battery, it sparks.

- I disconnected the positive lead from the starter solenoid to the starter and didn't have the same type of spark when connecting the negative lead to the battery.

- At least 2-3 times in past year the starter would continue to spin after the key was moved back into the on position (from start).

SuperMidget 04-28-2013 05:22 PM

Ignition switch sounds bad to me...

britt71 04-28-2013 06:11 PM

I'll go buy a replacement. But to be sure I understand, this is the switch in the dash or the key/lock mechanism on the steering column. I hope it's the former...Getting to the key mech looks like a pain (though what I've read of the switch in the dash, it sounds like a tight fit). Thanks for any advice you can provide.

SuperMidget 04-28-2013 11:39 PM

i've had a problem like this in a old chevy truck but it was the switch on the column the rod from the key switch runs to shorting out and kept my starter running if i even tried to move the key

n2trucking 05-01-2013 10:51 AM

ignition "SWITCH" not the whole cylender it self.

britt71 05-02-2013 08:03 PM

Thanks all. I replaced the switch and there is still a problem somewhere. I think there may be a short. I'll try more investigating and then take it to a professional if I can't figure it out. At least I now know how to replace an ignition switch. I can put that on the list next to roofing...things I don't want to do again.

bigtoysforbigboys 05-02-2013 08:33 PM

Sounds to me like the solenoid is stuck....try tapping on it with something ...should get your starter to stop

n2trucking 05-03-2013 11:06 PM

Quote:

Originally Posted by bigtoysforbigboys (Post 3712195)
Sounds to me like the solenoid is stuck....try tapping on it with something ...should get your starter to stop

Well it sounds like he is talking about his engine won't shut off and it's not the start motor but i'am not sure myself. I kind of thought the same thing when he said "motor" but the way it's worded i'm think he means engine.

n2trucking 05-03-2013 11:08 PM

I would say another thing to try is have the engine turned off and key out of ignition and see if you have any volts at the distributor hot wire. If so then im stumped and wouldn't know what else would keep volts at the distributor with the key out of ignition.

What engine is it?

britt71 05-04-2013 08:22 PM

Yep, I meant engine. Sorry about my incorrect terminology. I often use the wrong term. I'll remember one of these days. Motors are electrical...right?

I had replaced the starter. I'm fairly certain that's not the culprit.

Replaced the ignition switch, reconnected the battery and nothing at all happens when I turn the key. I assume I may have done something wrong when replacing the switch. It was at night and in the driveway. Rain has prevented me from working on it since. I'll go back and check everything I've already done.

Thanks again for all your input. I'm pretty much a novice but am learning. It's fun but frustrating too.

b_man360 07-13-2013 02:47 AM

get it fixed? I am having the same problem.

JHo303 07-13-2013 08:21 PM

here is a crazy one for ya...reconnected the choke linkage that had fallen off, turned the key, started and ran (very good) for 10 seconds, then died. Tried to start again, dead battery...0.7 VDC. Hooked up battery charger, shorted out. Took negative cable off, charger was fine...touched neg cable to battery and...POW...okay, direct short. Found fusible link from Alternator blown. Replaced link, hooked everything up one at a time (and tested). All good. Wierd.


All times are GMT -5. The time now is 12:55 AM.