Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   JK General Discussion Forum (http://www.wranglerforum.com/f274/)
-   -   Need clutch help please!!! (http://www.wranglerforum.com/f274/need-clutch-help-please-239079.html)

jerseyjk2007 04-29-2013 06:26 PM

I have a 2007 sahara 2 door. Just replaced clutch about a month ago driving home last night noticed that clutch started to have no tension. Went to go to work this morning and the pedal went right to the floor has no tension at all. What could it be Slave or Master?? Fluid in resovoir is a bit low. Shares the same as brake resovoir correct? someone help me please!!

WatchThis! 04-29-2013 06:50 PM

If I had to guess without seeing your jeep. I would say your slave cylinder is out.

jkjeeper06 04-29-2013 06:56 PM

Yes it shares the same reservoir as the brakes. At normal level, they share fluid, but if it gets too low there is a divider in there so that if one system goes and leaks out all of its fluid the other can still function. If your fluid is fine then that's not it.

Like watch this, I'd also guess slave cylinder

Chipmunk 04-29-2013 06:56 PM

I would also say slave. I have had this problem before with other manual trans...

jerseyjk2007 04-29-2013 07:01 PM

Thanks guys! I checked around the slave and master didnt see any signs of leakage. Brakes still works that's why I was leaning more towards the slave. Hopefully just need to swap the slave out. Easy fix? Take any help I can get!

WatchThis! 04-29-2013 07:05 PM

Never done one on a JK but I have never done one that was hard. They are a bitch to get all the air out of them sometimes.

Chipmunk 04-29-2013 07:08 PM

Quote:

Originally Posted by WatchThis! (Post 3698216)
Never done one on a JK but I have never done one that was hard. They are a bitch to get all the air out of them sometimes.

Ditto. All of the ones I have replaced have been manageable. Simple hand tools is all you need. As stated above, make sure to get all the air out

jerseyjk2007 04-29-2013 07:12 PM

Thanks guys. Fluid in reservoir is at the minimum line right now maybe just needs more fluid and to be bleed air in line possibly? Think I'm gonna try that first before I put a slave in it. Never had to bleed anything before any easy ways?

SilverSport 04-29-2013 08:02 PM

Quote:

Originally Posted by jerseyjk2007 (Post 3698187)
Thanks guys! I checked around the slave and master didnt see any signs of leakage. Brakes still works that's why I was leaning more towards the slave. Hopefully just need to swap the slave out. Easy fix? Take any help I can get!

A slave/master cylinder can be defective without it leaking. If the internal seals on the pistons get worn, fluid flows past the piston instead of being forced to move and do work.

jerseyjk2007 04-29-2013 08:16 PM

Thanks for the info! I'm gonna try and bleed the slave tomorrow if that doesn't work I'm gonna replace it and hopefully that will do the trick.


All times are GMT -5. The time now is 10:21 PM.