Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ Tech Forum (http://www.wranglerforum.com/f210/)
-   -   Oops!! Another wheel wobble... (http://www.wranglerforum.com/f210/oops-another-wheel-wobble-239136.html)

MadMike84 04-29-2013 09:06 PM

Oops!! Another wheel wobble...
 
So I hit a speed bump the other day going pretty fast... I know. I'm a dummy. Anyway now both front wheels wobble when turning and it seems as if I have to turn the steering wheel a lot farther than before to turn. No clinking or clanging in the steering box or underneath. I don't see anything bent . I will be checking ball joints and hub assembly tomorrow after work.

Just wanted to see if anyone's had this problem before and found out what it was. I'll post back with what I find tomorrow.

MadMike84 04-30-2013 10:09 AM

Not ball joints... Ughh I hate suspension... Hope I can figure this out

mrk130 04-30-2013 10:47 AM

What do you mean by both wheels wobble??

MadMike84 04-30-2013 01:45 PM

Quote:

Originally Posted by mrk130 (Post 3701222)
What do you mean by both wheels wobble??

Assuming my front right passenger side tires wobbling but I shouldn't assume I know for sure my driver side front tire is wobbling when I turn.. I just noticed when I turn my wheel when stopped its twisting my frame or something. The left side of my jeep raises up. I have 31 10.50 tires is that normal or is something bent and I can't see it...

RPM 04-30-2013 02:03 PM

Is the steering box ripped out of the frame ??? Have someone turn the wheel and watch the box engine running

Water Dog 04-30-2013 02:25 PM

Check your sway bar end links.

MadMike84 04-30-2013 05:53 PM

Steering box is ok, but I do see a "dent??" In the tube of the bumper above the box. I don't know how it's tight. And sway bar link on pass side is busted...I'm taking it to the shop soon to get alignment and see what's up . Just noticed its ******* my tires up big time

Atthehop 04-30-2013 06:48 PM

Sounds like bent tie rods.

Water Dog 04-30-2013 07:53 PM

Quote:

Originally Posted by MadMike84 (Post 3702731)
Steering box is ok, but I do see a "dent??" In the tube of the bumper above the box. I don't know how it's tight. And sway bar link on pass side is busted...I'm taking it to the shop soon to get alignment and see what's up . Just noticed its ******* my tires up big time

That must have been some kind of speed bump...!

kyjeep 04-30-2013 10:13 PM

The dent in the under side of the tube above the steering box is normal. But it does sound like you did something. Remind me not to come to your neighborhood. Those speed bumps sound like killers.

MadMike84 05-03-2013 07:33 PM

It was out of alignment. Nothing bent. I don't know how but that's all it was...lesson learned...WATCH out for speed bumps haha....


All times are GMT -5. The time now is 11:34 PM.