Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ Tech Forum (http://www.wranglerforum.com/f210/)
-   -   4.0L Misfire - Please Read (http://www.wranglerforum.com/f210/4-0l-misfire-please-read-240066.html)

Catnip 0_o 05-03-2013 07:17 PM

4.0L Misfire - Please Read
 
2002 TJ 4.0L 148k Miles

Alright so I'm starting to get real tired of all the repairs lately, it just seems like one after another. If you've seen my previous posts recently, you'd see that I was having steering play problems, luckily that is all take care of (finger crossed).

What is now happening is a problem I've been having for a long time, that I thought I fixed.

Symptoms: When driving the jeep at around 60-70 mph (2500-3000 rpms) my CEL will begin to flash signaling a misfire. It will then putter and when I pull up the code, I get the code for multiple/random misfire and a code for cylinder 3, 4, and 6. Well awhile back I thought it was fuel pump related because the fuel pressure was so low when I tested it, so I replaced the entire unit with a Spectra Premium. Shortly after, I still noticed at around 60-70 mph the CEL would flash. I've also replaced the spark plugs with both Champion OE and then tried Autolite Platinum. Replaced the Crank Position Sensor, Idle Air Control Sensor, and have thoroughly cleaned the throttle body.

Another strange symptom I have been having is when I first go to start it in the morning, I will start it, it will idle fine for about 5 seconds, and then begin to sputter for about 5 seconds and then fix itself, I am not sure if this is related or not.

Regardless, I really don't know what it could be anymore. Anyone else have the same problem or suggestion? I have read in the past 97-03 TJs have a problem with misfire after they change the Crank Sensor, but I am not sure...

Any advice/help is appreciated as always..

Tomdata 05-03-2013 07:21 PM

Check/wiggle crank sensor connector. Also check wiring harness on left rear of valve cover for rubbing damage.

MOTO X TJ 05-03-2013 07:29 PM

I had a near identical problem on a 97 2.5L .... chased it for months. Tried milultiple fixes and it would smooth out for a bit then the problem would come back. Found the issue was damage to the above mentioned wire harness. I had a bit of a cherry on top though.....the wire harness being damaged resulted in the pcm being fried so I had to get a replacement for that as well. I am hoping if your issue is the wire harness, you will catch it before it hurts the pcm. Not saying this is your problem for sure but just what happened to me. Worth checking though. Good luck!!


All times are GMT -5. The time now is 10:35 PM.