Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   YJ Build Forum (http://www.wranglerforum.com/f330/)
-   -   Jeep 1990 YJ nuttered,motorcraft no vacuum leaks won't idle runs crazy rich. (http://www.wranglerforum.com/f330/jeep-1990-yj-nuttered-motorcraft-no-vacuum-leaks-wont-idle-runs-crazy-rich-240240.html)

dovedude 05-04-2013 05:07 PM

Jeep 1990 YJ nuttered,motorcraft no vacuum leaks won't idle runs crazy rich.
 
Alright guys, just purchased a 1990 jeep YJ 4.2 with the 5 speed. It ran great in all gears but wouldn't hold an idle and died when I put the clutch in at stops. I tried the nutter..nothing. So I installed the motorcraft 2150 from the eBay guy with no change. Triple checked the vacuum lines and timing. Had a loose intake bolt fixed that. New plugs,wires,coil,cap still runs super rich and dies. The starter grinds sometimes when trying to fire and it sat for about a year. It does have exhaust leak at the donut i think as well. Any ideas?

dovedude 05-04-2013 06:46 PM

So next two things I am going to try are the icm and do a fuel pressure and ill update then. Any other help would be greatly appreciated. Thanks!

Beachcruiser 05-05-2013 10:34 AM

I always like to start w/ the basics: compression test, basic electrical, etc. If you have poor compression, then it will be next to impossible to get it to run correctly.

You shouldn't have a rich condition w/ the new carb if it is set up right. The stock carters are notorious for plugging up & conking out at idle, but the MCs will idle down to 500, smooth as silk.

The ICM is a possibility, but they usually just go out.

Fuel pressure should be fine if you kept the return line to the tank (that bleeds off excess pressure).

Have you checked all the grounds in the engine bay? You may be getting a very weak spark at speeds not high enough to trip the alternator into charging. I'd freshen up all your contacts on the battery, cables & ground wires...especially the ones connected to the engine & charging system.

Nubby55 05-05-2013 10:44 AM

put a vacuum gauge on it and adjust the low speed needles, if that's not it check the power valve.

Jerricho 05-06-2013 10:14 AM

Check the timing too, of it was not set right when it got Nuttered, or slipped it can cause a bad idle.


All times are GMT -5. The time now is 08:09 PM.