Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   Communications and Electronics (http://www.wranglerforum.com/f40/)
-   -   Dash Stock TJ Speakers (http://www.wranglerforum.com/f40/dash-stock-tj-speakers-240541.html)

Duckmasterlack 05-06-2013 09:01 AM

Dash Stock TJ Speakers
 
I purchased a 1999 TJ that the PO installed an aftermarket head unit. I noticed that the only speakers that are working is the sound bar. After a little research I found that there are two speakers in the dash are not working.

Is this a common problem with the stock dash speakers to blow or do I have some other problems further up the line. I removed the covers and the speakers put a volt meter on the connections and i am getting around 2.5 volts when the radio is on.

Is it possible that the speakers are blown and I can slap in a new set of speakers and I'm good to go.

Jerry Bransford 05-06-2013 11:25 AM

With both front speakers out, I probably wouldn't suspect them. Could your radio's fader control be set all the way to the rear so only the rear speakers are getting power?

Duckmasterlack 05-06-2013 12:11 PM

That is the first thing I tried. When I fade to the front there is no sound not even static. I have had experiences with blown speakers before and most of the time there will be some feedback. I was wondering if this is a common thing with the dash speakers on the early model TJ's.

CoreyZ 05-07-2013 10:32 AM

Perhaps they arent even hooked up?

Did they install a new amp also?

Duckmasterlack 05-07-2013 01:05 PM

I can't tell if an amp was installed at one point or another. I'm thinking about taking a speaker out of my sound bar and plunging it in to the front speaker if they have the same harness connection. The sound bar speakers work fine and should give me an indication if the wiring is still good or if I have to trace the problem back to the head unit.


All times are GMT -5. The time now is 08:51 PM.