Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ General Discussion Forum (http://www.wranglerforum.com/f282/)
-   -   what's going on here... (http://www.wranglerforum.com/f282/whats-going-on-here-241795.html)

_plaisance 05-10-2013 02:34 PM

what's going on here...
 
1 Attachment(s)
Started this morning

Attachment 247567

Jaxon1023 05-10-2013 03:00 PM

Oil pressure sending unit is bad

monkeee2002 05-10-2013 04:35 PM

Yep, that's what mine did. Swapped the sending unit (easy on a 4.0) and all was good!

_plaisance 05-10-2013 04:46 PM

Yeah the mechanic at the fire station told me the same thing thank y'all for the help!

_plaisance 05-13-2013 02:47 PM

Where is the sending unit at?

SinfulDragon 05-13-2013 02:51 PM

was your jeep rolled over when you took this picture? how is your hand on your phone, on the top to take this picture unless you are on your head.

Ohhhh, you're talking about the oil sending thingy ma bopper, the picture was far more interesting.

Here are some pics/tips of where it is and how to get it off.
http://www.wranglerforum.com/f5/pics...ion-70915.html

_plaisance 05-13-2013 07:07 PM

Quote:

Originally Posted by SinfulDragon (Post 3751230)
was your jeep rolled over when you took this picture? how is your hand on your phone, on the top to take this picture unless you are on your head.

Ohhhh, you're talking about the oil sending thingy ma bopper, the picture was far more interesting.

Here are some pics/tips of where it is and how to get it off.
http://www.wranglerforum.com/f5/pics...ion-70915.html



lol no my phone likes to upload pics sideways for some strange reason no matter what i do to the pic its retarded


All times are GMT -5. The time now is 10:04 PM.