Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   Communications and Electronics (http://www.wranglerforum.com/f40/)
-   -   Z10 BB problems with Uconnect (http://www.wranglerforum.com/f40/z10-bb-problems-with-uconnect-241853.html)

hhz 05-10-2013 09:25 PM

Z10 BB problems with Uconnect
 
Anyone having trouble with Uconnect with new Blackberry Z10 phone? My 2012 Wrangler with 730N nav unit will not recognize the phone with BT discoverable turned on, nor will the phone recognize the Jeep. Jeep connected fine to prior BB 9700 and new Z10 connects to my other vehicle and BT earpiece. Jeep website says I have latest software for the 730N. I'm stumped.

xsdbs 05-22-2013 07:22 AM

I have a friend that has the Z10 and it works well with his 730N. What SW do you have on the phone? His is:
10.0.09.2372




Quote:

Originally Posted by hhz (Post 3743019)
Anyone having trouble with Uconnect with new Blackberry Z10 phone? My 2012 Wrangler with 730N nav unit will not recognize the phone with BT discoverable turned on, nor will the phone recognize the Jeep. Jeep connected fine to prior BB 9700 and new Z10 connects to my other vehicle and BT earpiece. Jeep website says I have latest software for the 730N. I'm stumped.


supercazzola 05-22-2013 07:37 AM

I'm not 100% sure, but it seems uconnect module is separate from radio. So when you upgrade firmware on radio, it actually changes the way the s/w interfaces between the radio and the uconnect module. But wouldn't the s/w on the uconnect module not change? Unless they flash the module for uconnect? I've seen intermittent issues with multiple devices on my vehicle, even when I swapped out a RES radio for a new RBZ. What stayed the same? The uconnect module. So not sure how flashing the radio would fix a design flaw with uconnect. It could only patch how the radio talks /interfaces to the module.
Just my thought, but after swapping out radios, I'm gonna stick with my hypothesis.

xsdbs 05-22-2013 10:27 AM

There are 3 different suppliers for the Uconnect system. Depending on which radio that you have, you're correct about Uconnect being an external module. Radios REQ, RES, RBZ & RHB all have an external module while the 730 & 730N have internal Uconnect. So in the case of the OP, his radio SW update would also have the Uconnect SW in it. The other listed radios would have separate SW versions for the radio & Uconnect.
Now because there are 3 different mfg's for the Uconnect, several different SW writers and the fact that the BT specs aren't tightly regulated this leaves the specs to be interpreted differently by each SW writer. This leaves the door wide open for a phone to work with some radios but not others. Of course this isn't only with the Chrysler Uconnect system. It's true with other vehicle mfg's as well. Where a phone may work with Chrysler but not a different vehicle mfg.
There was an issue with the first released BB Z10 phones and the way the phonebook contact info was being sent from the phone when pairing, but BB released an update for this phone a short while back.





Quote:

Originally Posted by supercazzola (Post 3780878)
I'm not 100% sure, but it seems uconnect module is separate from radio. So when you upgrade firmware on radio, it actually changes the way the s/w interfaces between the radio and the uconnect module. But wouldn't the s/w on the uconnect module not change? Unless they flash the module for uconnect? I've seen intermittent issues with multiple devices on my vehicle, even when I swapped out a RES radio for a new RBZ. What stayed the same? The uconnect module. So not sure how flashing the radio would fix a design flaw with uconnect. It could only patch how the radio talks /interfaces to the module.
Just my thought, but after swapping out radios, I'm gonna stick with my hypothesis.



All times are GMT -5. The time now is 02:55 AM.