Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   JK General Discussion Forum (http://www.wranglerforum.com/f274/)
-   -   Help Dead 2012 (http://www.wranglerforum.com/f274/help-dead-2012-a-242056.html)

joe buell 05-11-2013 10:28 PM

Help Dead 2012
 
:facepalm:Well took my mother out to eat for moms day on sat to beat the Sun rush anyway we started to leave turned the key on my 2012 2dr sport and the dash lights looked like the 4TH of July right down to the sizzle flicker/flash get bright go dim well my brother was there . we opened the hood and you could hear clicking from the fuse panel without the key in ignition. it turned out clicking is coming from the ignition relay took relay out and it continued disconnected bat for 10min to try to reset no use even with the key out and the lights turned off. the parking lights and headlights would flicker very dimly called roadside assist and they sent a tow well could not get it in neutral with key all the way on when the tow guy hooked jump box to it it was enough to get it in neutral but then key would not come out well got it to local dealer of course not open till Monday if anyone has any ideas I would love to hear them thanks Joe. until then :banghead:

BillyPete 05-12-2013 12:43 AM

Sounds like a fried Power Distribution box to me.

joe buell 05-12-2013 05:50 AM

Thanks BillyPete the way all the lights were flickering even with key out and every thing in the off mode that's kind of what I was thinking Brain type issue you would like to at least see more than 14k on odometer before something like this happens?Thank God for warantee.I wonder how many have had this issue? thanks again Joe.

kjeeper10 05-12-2013 06:21 AM

Oooh Joe. Hope it's something stupid :(

joe buell 05-12-2013 06:31 AM

Praying for bad batt but after jumping for 10min had enough juice to run all lights including KC lights then right back to stupid mode this is my company vehicle I need for work so hoping for QUICK FIX???? I'll see what happens Monday will repost results may help someone in the future. Joe.

ilikeguns 05-12-2013 06:37 AM

good luck man.. keep us posted

SafetyThird 05-12-2013 09:58 AM

Quote:

Originally Posted by joe buell
Praying for bad batt but after jumping for 10min had enough juice to run all lights including KC lights then right back to stupid mode this is my company vehicle I need for work so hoping for QUICK FIX???? I'll see what happens Monday will repost results may help someone in the future. Joe.

My first thought on any electrical weirdness is bad ground. Power wants ground and when it can't get there the right way it goes through other circuits the wrong way.

Good luck.

joe buell 05-15-2013 03:16 PM

Well I went to the dealer Mon morning and talked to service rep he said 90percent sure it was the batt so I left it and went home 2hrs later he called and said it was ready it was the batt but I have never seen any vehicle do such and to not start even after a jump????Happy Happy Happy . and BTW FYI your Chrysler roadside service towing only covers the 1st $100 of any tow so if you are aways away you might want to use your insurance instead just thought that was kinda weak only $100 for a tow but alls good thanks to the ones that took the time to try to help Joe.

cbell77 05-15-2013 04:40 PM

My old Lancer had one of the cells go bad in the batt. Still had enough power to make everything go crazy like you said plus it sounded like their was a pissed off squirrel with a machine gun under the hood.

ilikeguns 05-15-2013 04:44 PM

glad it worked out for you man..

lesgoff 05-15-2013 04:51 PM

Similar problem with my BMW. I went into a restaurant for lunch, came out and it wouldn't do anything (not even a click). I called BMW (still under the 3 year maintenance free service) and they couldn't even jump the car. They towed the car to the dealership and it was a bad battery. Replace free of charge and sent me on my way.


All times are GMT -5. The time now is 03:56 AM.