Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   JK General Discussion Forum (http://www.wranglerforum.com/f274/)
-   -   ESID and evap codes (http://www.wranglerforum.com/f274/esid-and-evap-codes-242749.html)

_3m 05-15-2013 07:58 AM

ESID and evap codes
 
I was told that many of the small evap leak code are due to the ESID being dirty and stuck in one position or another, Has anyone had any experience with this? where is it located?

tabber02 05-15-2013 08:01 AM

the EVAP is about two thirds of the way back... closer to the drivers side and next to your exhaust. it's a black box... about 10"x10" if i had to guess..

_3m 05-15-2013 08:35 AM

ESID is the white box on the trailing side of the evap canister. And mine was sliding side to side just fine. Back to square one

tabber02 05-15-2013 08:41 AM

hmm.. you nail the EVAP on something? maybe the connector is junked up with dirt?

JeepHerz 05-15-2013 11:49 AM

Have you done anything to the evap. prior? We had the same code- messed with the canister when we did our gears. Lost a gasket somehow. $3 from the dealer and the code went away.
It threw both codes at the time- someone mentioned the gas cap can throw the evap. code. (even though there is a gas cap code). Easy enough to try and un-do and re-do your gas cap.

JPi4.0 05-15-2013 12:02 PM

Quote:

Originally Posted by JeepHerz (Post 3757826)
Have you done anything to the evap. prior? We had the same code- messed with the canister when we did our gears. Lost a gasket somehow. $3 from the dealer and the code went away.
It threw both codes at the time- someone mentioned the gas cap can throw the evap. code. (even though there is a gas cap code). Easy enough to try and un-do and re-do your gas cap.


i chased and chased this leak on mine. i never had a seal. Jeremy's had the same problem. no seal. we have seen quite a few come in without a seal. the seal is cheap but it just became available from the dealer. a year ago you couldn't get the seal.

so no worries you didn't loose it.

_3m 05-15-2013 03:00 PM

2 Attachment(s)
Well after checking everything I could on the rear side and replacing the gas cap I traced the lines to the front and found the leaking hose. It's the hose that comes from the back and bends around the battery. Mine was leaning up against the battery and had the battery has rubbed a hole in the hose. See photo

Attachment 249450





Attachment 249451

I put some heat shrink on it and taped it up. I'm hoping that does the trick. But I would encourage everyone to have a look at theirs. I also looked at my girlfriends jeep as she's having the same issue & sure as heck same hole in the same spot.

_3m 05-15-2013 03:06 PM

next question: will the computer reset itself from this code or do I need to reset it myself and then drive a bit? i have a state inspection in the AM and i know the 0456 is an automatic fail.

JPi4.0 05-15-2013 03:09 PM

Quote:

Originally Posted by _3m (Post 3758548)
next question: will the computer reset itself from this code or do I need to reset it myself and then drive a bit? i have a state inspection in the AM and i know the 0456 is an automatic fail.

Yes. I think after five cycles. Mine reset about ten minutes after I fixed it.

_3m 05-15-2013 03:32 PM

shesh maybe i didn't Fix it. well I did in a sense. i drove nearly 50 miles today with it fixed on the highway and the engine light is still on. the code is gone but the light remains on. i did shut it off a number of times but cant say for sure if it was more than 5.

JPi4.0 05-15-2013 04:36 PM

Quote:

Originally Posted by _3m (Post 3758644)
shesh maybe i didn't Fix it. well I did in a sense. i drove nearly 50 miles today with it fixed on the highway and the engine light is still on. the code is gone but the light remains on. i did shut it off a number of times but cant say for sure if it was more than 5.

Two of our shop jeeps reset themselves. Maybe you have another code?

_3m 05-15-2013 08:27 PM

I disconnected the battery, reset it and drove 130 miles, no code no engine light. Fingers crossed


All times are GMT -5. The time now is 12:12 PM.