Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   JK General Discussion Forum (http://www.wranglerforum.com/f274/)
-   -   Coolant disappearing in the over flow bottle. (http://www.wranglerforum.com/f274/coolant-disappearing-in-the-over-flow-bottle-243648.html)

Miser 05-19-2013 12:47 PM

Coolant disappearing in the over flow bottle.
 
I have now owned my 2013 Wrangler just about 3 months, but it only has about 1,200 miles on it.
From new to current, my coolant in the overflow bottle has dropped in level by about 2 inches. I always check it cold in the morning, before start up.
I looked over the hose connections and water pump and have found no visible leaks. It also does not build up when hot and go out the overflow. The coolant level is now about where it should be verses the bottle level mark.
My oil level is correct and not milky.
My thinking is that there was probably some air in the system that over time has bled out and the coolant sucked back in on cool down.

ANY OTHER THOUGHTS ON THIS?

SilverSport 05-19-2013 02:02 PM

Could be air worked itself out. Didn't someone else recently have a similar problem and the radiator cap was fubar?

Miser 05-19-2013 03:10 PM

Quote:

Originally Posted by SilverSport (Post 3771361)
Could be air worked itself out. Didn't someone else recently have a similar problem and the radiator cap was fubar?

Earlier on I had a issue where the cap wouldn't allow the coolant to be drawn back into the radiator when cooling down. Dealer replaced the cap.
Everything coolant level wise seemed to work normal after that.
On rare occasions I would hear some of the gurgling sound from the heater core, but haven't heard that for quiet some time. I just turned my heat up to help the air circulate through the core.
But just recently noticed my coolant level decreasing slowly over time.

There may have been some others also with cap issues.

I'm hoping that it is just air bleeding itself out. We are leaving this Thursday for our cabin up on the Rim and I don't need any cooling system problems. It doesn't run hot. I will finally have a opportunity to try this new Rubicon out back in the woods and there are some really good rock crawling area's as well. This is my first Wrangler with lockers so I plan on putting them to the test. :thumb:

kik 05-19-2013 03:48 PM

You may or may not have a slight leak. I would have the dealer pressure test the system. If everything checks out then you're most likely ok. A visual inspection sometimes doesn't catch small annoying leaks.


All times are GMT -5. The time now is 11:53 AM.