Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ Tech Forum (http://www.wranglerforum.com/f210/)
-   -   Losing power (http://www.wranglerforum.com/f210/losing-power-244069.html)

Rob35pa 05-21-2013 08:44 AM

Losing power
 
Every so often my 97 will act up. It will hesitate no matter how much gas you give it. Also it will sound like it is backfiring through tha carb. It will pop n act up but if you pull over and put it in park it revs up fine. Any thoughts?

Lando25 05-21-2013 12:18 PM

Quote:

Originally Posted by Rob35pa (Post 3777586)
Every so often my 97 will act up. It will hesitate no matter how much gas you give it. Also it will sound like it is backfiring through tha carb. It will pop n act up but if you pull over and put it in park it revs up fine. Any thoughts?

No carb on a 97, everything in the TJ was fuel injected. Do you get a CEL (check engine light) when this happens?

jeepndon 05-21-2013 12:36 PM

Quote:

Originally Posted by Rob35pa (Post 3777586)
Every so often my 97 will act up. It will hesitate no matter how much gas you give it. Also it will sound like it is backfiring through tha carb. It will pop n act up but if you pull over and put it in park it revs up fine. Any thoughts?

I would first start out looking over the ignition system check the Plugs, Wires, cap and Rotor. make sure the Spark plug gaps are fine look for the gap setting on the white sticker under the hood should be .035. Next check for cracks in the CAP or corrosion on the terminals in the cap.

Rob35pa 05-21-2013 06:28 PM

Last time I got the code checked I got a generic code that coulda been emissions.


All times are GMT -5. The time now is 03:10 PM.