Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   JK General Discussion Forum (http://www.wranglerforum.com/f274/)
-   -   AEV Dualsport 2.5 (http://www.wranglerforum.com/f274/aev-dualsport-2-5-a-244520.html)

m25red 05-23-2013 12:26 AM

AEV Dualsport 2.5
 
Just finished installing this lift with a buddy earlier tonight. Everything went fairly smooth with the exception of the passenger front shock. But I knew ahead of time.
The thing is I have this rattle sound coming from the front drivers side. Only noticeable when suspension moves. I think it may have something to do the sway bar links but I'm really not sure.
If any of you have a clue what this may be please let me know. We did torque everything as we should. Also if you have a pic of the front sway bar links please show.

DallasJKU 05-23-2013 12:46 AM

Quote:

Originally Posted by m25red (Post 3784339)
Just finished installing this lift with a buddy earlier tonight. Everything went fairly smooth with the exception of the passenger front shock. But I knew ahead of time.
The thing is I have this rattle sound coming from the front drivers side. Only noticeable when suspension moves. I think it may have something to do the sway bar links but I'm really not sure.
If any of you have a clue what this may be please let me know. We did torque everything as we should. Also if you have a pic of the front sway bar links please show.

Did u use the swaybar brackets from AEV??

Flint_Holbrook 05-23-2013 05:34 AM

I finished installing my AEV 2.5 inch lift yesterday. I could/did not get the front brakeline brackets loose from the brake lines but tie wrapped them to the shocks. They may create a rattle if you are not careful in how you do this. It took me many more hours than it should have but I did it mostly by myself with some help from my 19 year old as he would come in and out. I measured 2.8 inches of lift on the front.

dreinecke 05-23-2013 07:21 AM

Verify everything is retorqued before you do any real driving with it. Double check you haven't forgotten one bolt.

If you didn't cut and break off the brake bracket that would be my guess too. Use a dremel with A cutting wheel to carefully cut it and then use some channel locks to break it off - just don't kiss the brake line.

m25red 05-23-2013 07:41 AM

I did use the sway bar brackets from AEV. The brake line bracket was PITA for sure but got that done as well. I am installing the geometry brackets tonight so I guess I will re-torque everything again and see what happens.
It just sounds like loose linkage and I feel so damn sure everything was good as we triple checked all bolts.

jadmt 05-23-2013 08:37 AM

lift the front off the ground and shake the front wheel and turn it side to side wiggle everything underneath too etc

m25red 05-23-2013 09:05 AM

Quote:

Originally Posted by jadmt
lift the front off the ground and shake the front wheel and turn it side to side wiggle everything underneath too etc

Will do. Can't wait to get it dialed in. Love the stance.

m25red 05-23-2013 10:04 PM

The culprit was a loose LCA on the drivers side. Installed the geometry brackets, re-torqued everything and she drives like a dream. Can't wait to see how she rides off pavement. No rocks here so I'm expecting things to go well.

fishmd 05-24-2013 02:41 PM

Quote:

Originally Posted by m25red (Post 3787455)
The culprit was a loose LCA on the drivers side. Installed the geometry brackets, re-torqued everything and she drives like a dream. Can't wait to see how she rides off pavement. No rocks here so I'm expecting things to go well.

How much lift you end up with?

m25red 05-24-2013 05:25 PM

Quote:

Originally Posted by fishmd

How much lift you end up with?

About 3 in the front and in back. Very loose numbers. I will get a better measurement after it settles.

fishmd 05-25-2013 07:49 AM

Quote:

Originally Posted by m25red (Post 3790096)

About 3 in the front and in back. Very loose numbers. I will get a better measurement after it settles.

Cool, would be interested to know.

scrimat 05-29-2013 02:47 PM

Just got mine installed over the weekend. After it sat for a little over a day it settled in to almost exactly 2.5" in the rear and about 2.7" in the front.

I was a little concerned with how hard I had to push the front axle towards the driver's side to get the track bar hole to line up. The sway bar end links don't hang straight down either, they're angled towards the driver's side. Is this normal? I'm guessing the only way to fix it is with a longer track bar.

mboyda 06-13-2013 10:37 AM

AEV JK DualSport XT Suspension 2.5 Install - 4 Wheel Drive & Sport Utility Magazine

Just found this. Ordering mine soon.

Spyder1049 06-13-2013 10:59 AM

I'm installing mine this Saturday with a little help from my friends :-D

DallasJKU 06-13-2013 12:42 PM

Quote:

Originally Posted by m25red (Post 3790096)
About 3 in the front and in back. Very loose numbers. I will get a better measurement after it settles.

I know I got at least 3" even with front PS Brawler lite bumper and rear MetalCloak bumper and TR tire carrier.

85CJ 06-13-2013 03:30 PM

Just got mine installed yesterday, love it!
 
1 Attachment(s)
Here is a pic


All times are GMT -5. The time now is 04:47 AM.