Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   YJ Tech Forum (http://www.wranglerforum.com/f218/)
-   -   HELP!!! sudden loss of all gauges (http://www.wranglerforum.com/f218/help-sudden-loss-of-all-gauges-244812.html)

petercass88 05-24-2013 12:50 PM

HELP!!! sudden loss of all gauges
 
Parked my 95 to go grab some lunch at the mall. I come back out and all gauges (tach, speedo, oil pressure, temp, etc) are completely dead aside from the fuel gauge. What the heck happened??? :-(

fire66dave 05-24-2013 01:13 PM

Fuse?

petercass88 05-24-2013 01:19 PM

Dumb question... where are the fuses located? I have been trying to read through this forum post but im just scratching my head: http://www.wranglerforum.com/f8/help...ng-221622.html

Manshoon 05-24-2013 01:21 PM

There is a fuse block under the dash to the left of the steering wheel, start there.

found another post that guys where having problems with #9 / 15 amp fuse ign / lmps under the dash. My fuse was blown and I take out the fuse block next to check for corrosion.

sevenservices 05-24-2013 01:25 PM

just curious lol, did it rain hard with the top off while you were in the store? That would do it ;) and usually they break on the trials, not at the mall lol

If not, I would first lay under the dash there and look for anything loose, hanging, etc... Also make sure that if you have a smaller accessory wire on the + battery terminal that its not broke free from the connection.

petercass88 05-24-2013 02:28 PM

No rain and the parking lot was certainly paved :surrender: :hide:

I will say that there are random wires hanging under the dash as well as the head unit shuts off if you touch the buttons any harder than the pressure needed to depress them. I will take some pictures later when I am home. Under the drivers side to the left of the steering wheel there is a little dome light that was on. I havent seen that before...

petercass88 05-24-2013 03:21 PM

I a not very good at all things electrical... I am going to head over to my friends house this afternoon and see if we can find anything. I will report back and take some photos as well.

Thanks!

Quote:

Originally Posted by Manshoon (Post 3789180)
There is a fuse block under the dash to the left of the steering wheel, start there.

found another post that guys where having problems with #9 / 15 amp fuse ign / lmps under the dash. My fuse was blown and I take out the fuse block next to check for corrosion.


petercass88 05-24-2013 09:40 PM

here is my under-the-dash mess that i need to get around to when i monstaliner the interior...

http://i.imgur.com/dwYsrR2.jpg

http://i.imgur.com/fbDMZUk.jpg

http://i.imgur.com/LCxvSNm.jpg

http://i.imgur.com/Dbq9OTT.jpg

http://i.imgur.com/6ZRGaL1.jpg

http://i.imgur.com/hs7X4nV.jpg

http://i.imgur.com/PnOinSi.jpg

http://i.imgur.com/uttdLg5.jpg

http://i.imgur.com/yHqvKSc.jpg

http://i.imgur.com/XwFjEM9.jpg

petercass88 05-24-2013 09:42 PM

I didnt notice any numbers on the fuse box, just labels as you can see in the photos.

petercass88 05-25-2013 02:50 PM

Sorry for yet another post - I replaced the fuse that you all suggested and I am back up and running! PO had a set of spare fuses... I hope that isnt a sign of things to come?


All times are GMT -5. The time now is 06:52 PM.