Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   YJ Tech Forum (http://www.wranglerforum.com/f218/)
-   -   1995 Wrangler YJ fuel problems/Not Starting (http://www.wranglerforum.com/f218/1995-wrangler-yj-fuel-problems-not-starting-247000.html)

1995jeepwrangleryj 06-03-2013 11:11 PM

1995 Wrangler YJ fuel problems/Not Starting
 
Hey whats up guys...So I just bought a 1995 Wrangler YJ 2.5 Inline 4 cylinder...Jeep is not running was told by previous owner that he was stopped at a red light and jeep turned off and hasnt started since...I saw Jeep sitting i his backyard for a year then I came and bought it...I put a battery in it and car cranks over but does not start..
1. checked main fuel line and noticed that there was no fuel being delivered
2. changed fuel pump but still no fuel being delivered
3. checked fuses and still no fuel delivered and jeep just cranks over

Please if anyone can help me out with this problem I would greatly appreciate it....

Thanks Alex

AllMudd 06-04-2013 12:07 AM

Where are you checking for fuel at?

AllMudd 06-04-2013 12:08 AM

Also do you hear a humming when you take off the fuel cap? If not then the pump isn't turning on

1995jeepwrangleryj 06-04-2013 01:47 AM

No humming noise so I know fuel pump isnt getting power, however I dont know why it is not getting power...I am checking for fuel on the main fuel line in the motor

tim2 06-04-2013 03:15 AM

Check and clean the c104 relay mounted on the firewall next to the battery. I had the same problem and it took a long time to find that this relay was dirty and causing the same not fuel delivery problem.

indirocz28 06-04-2013 07:14 AM

Also, check at the connector in the rear left corner to see if you are getting power back there.

We know you replaced the pump, but it doesn't hurt to verify power coming or not coming through the connector.

Also check for wiring harness' that have possibly been chewed by rodents.

I just had to diagnose a Jeep ZJ where it quit, and the owner searched for the issue for about 3 weeks until he asked me to look at it.

1995jeepwrangleryj 06-05-2013 12:07 AM

So I tried pouring gas down the throttle body just to see if I could get the motor fired up but still not starting just cranks over...

1995jeepwrangleryj 06-05-2013 12:07 AM

Any other useful hints.....

indirocz28 06-05-2013 12:36 AM

Bad crank sensor?

Have you tested for spark?

AllMudd 06-05-2013 01:22 AM

I can't remember but is there a fuel pump relay under the hood by the battery? And sounds like you have more than one problem since fuel directly into the engine it won't fire.

tim2 06-05-2013 03:45 AM

Yes there is a pump relay located in the fuse box located right in front of the battery.


All times are GMT -5. The time now is 07:56 AM.