Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ Tech Forum (http://www.wranglerforum.com/f210/)
-   -   3rd rear main seal??? (http://www.wranglerforum.com/f210/3rd-rear-main-seal-24787.html)

jeepjeep 01-05-2009 08:55 PM

3rd rear main seal???
 
So i picked up my truck from the dealer with the 3rd rear seal installed. mine keeps leaking ,anybody else? If it happens one more time then i am going to raise some hell w/ chrysler(not that will actually do anything!!).It has to be either a scarred crank flange or installed incorrectly.:banghead:

And on another rant who where has a six-speed trans, does it grind sometimes going into 2 or 3?just curious...:confused:

orange05tj 01-05-2009 09:00 PM

Rear seal changed at 19k then again at 26k, and its leaking again at 47k. They put some dye crap in it and then told me my warranty was expired after they changed the power steering pump, tensioner and belt at 38k miles. I have the 6 speed, havent had any probs with it....yet.

Joe Dirt 01-06-2009 01:06 AM

I have an 03 and had a similar issue. Fortunetly I had an honest dealer who looked deeper. He told me my engine had been assembled in a faulty manor. The crankshaft was loose. They replaced the entire engine free.

jp'rs_peep'rs 01-06-2009 01:53 PM

WOW! WOW! WOW!
Now that is a dealer worth going too!

Man if only we had dealers here in SE WI who behaved that way...The ones here in my home town have been well less then pleasant.

LOL!

jeepjeep 01-06-2009 05:07 PM

less pleasent... same for sure... my truck is back at the dealer right now, they replaced the release bearing last week (mon thru wednesday) I picked it up after hours since they closed early new years eve. well when i picked it up that night as soon as i started it the trans was really banging around loud!! So then I looked around under it and found a sheared off bolt(from tranny mount to skid plate). My 4wd light does not come on now(which the left the sensor unpluged), it locks in 4lo, and the new release bearing squeaks when hot!!!WTF?so i called them on friday , they said to bring it in monday. I dropped it off sunday night, got no call on monday or tuesday, so i call them, they told me they were replacing the mount but my clutch is bad making the banging sound?? It never did it before they dropped the trans to replace the first release bearing, i am going to give them until tomorrow to do the right thing if they dont then i guess i will be contacting chrysler...t.b.c.


All times are GMT -5. The time now is 11:53 PM.