Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   YJ Tech Forum (http://www.wranglerforum.com/f218/)
-   -   Please help,my wrangler will not stay running. (http://www.wranglerforum.com/f218/please-help-my-wrangler-will-not-stay-running-247881.html)

c5wagner 06-07-2013 05:48 PM

Please help,my wrangler will not stay running.
 
I have a 1989 wrangler 4.2l carbureted motor that will not stay running. I have changed the ignition control module, spark plugs/wires/cap, fuel filter, and rebuilt carb. The Jeep will start, run for a bit, then die without warning almost like it is being flooded or no fuel. Could this be the fuel pump not working?

rolltide14 06-08-2013 10:56 AM

look down the carb and see if there is fuel dripping when you have it idleing. if so pull venturie assembly and clean idle tubes. search easy fix for 258 idle problems that may be it. it's a constant problem with Carter's.

c5wagner 06-08-2013 01:40 PM

My carb was just rebuilt so I don't think this is the issue. It had the problem before the rebuild and after.

indirocz28 06-08-2013 06:12 PM

May want to check out my thread here: http://www.wranglerforum.com/f8/anot...ue-245479.html

I had the exact same issues. My carburetor was a re-man for 2011.

c5wagner 06-09-2013 08:23 PM

Well I am not able to do a carb swap where I live, or I would have done it already.

indirocz28 06-09-2013 10:41 PM

Some people from CA have been discussing a carb swap. Maybe worth checking into to find out for sure.

I do still have my carter though if you're looking for a spare.

c5wagner 06-10-2013 05:02 PM

A spare would be nice, maybe a mix and match of the parts

indirocz28 06-10-2013 05:47 PM

The throttle shaft is what is leaking on mine, but i mean if you want it I'll sell it cheap enough I think.

c5wagner 06-16-2013 03:49 PM

Well I seem to have the same problems, and my jeep hasn't moved in 3 weeks. Any help would be appreciated. I've swapped the carb so it is different from my old one, new fuel filter/pump, new ignition control module, new cap/rotor/wires/plugs/and ignition coil, and I still have no idea what the problem is.

indirocz28 06-16-2013 04:48 PM

so it won't idle at all?

Check for vacuum leaks man.

c5wagner 06-17-2013 04:23 PM

Unfortunately, my car won't stay running long enough to check for vacuum leaks. It will start then just die a few seconds-minutes later. I did replace all the vacuum lines a few months ago.

indirocz28 06-17-2013 07:00 PM

will it stay running if you give it gas?

c5wagner 06-18-2013 09:13 PM

So I figured it out. When I changed my gas tank about 2 months ago, I guess I pinched my fuel line putting the new tank in, but the problem didn't start until 3 weeks after.

indirocz28 06-18-2013 10:08 PM

So are you 100% sure you fixed the problem?

c5wagner 06-19-2013 01:36 AM

Oh yes, now my wrangler runs better than ever with all the new parts.

indirocz28 06-19-2013 06:28 AM

Great! Glad you got it fixed!


All times are GMT -5. The time now is 02:36 PM.