Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ General Discussion Forum (http://www.wranglerforum.com/f282/)
-   -   Help (http://www.wranglerforum.com/f282/help-247957.html)

johnny102393 06-08-2013 03:01 AM

Help
 
Hey everyone I just turned 128,000 miles and my jeep is overheating It was boiling over into the tank but I replaced the rad cap and it releases pressure occasionally but now it cracked the top of the Rad and singed the A/C sticker im going to need a new Rad and im sure a new thermostat but please tell me if im wrong oh btw my temp gauge doesn't go past 214 even when the coolent is boiling.

2nd issue

so when I drove off today I noticed that my oil pressure is higher than normal almost hit 80 and normally runs about 60 high (I run thicker oil in the summer since im in AZ) but 80 is way high. is it just the sending unit?

I appreciate any feedback and im not scared of putting good parts in my jeep it needs to last longer than shorter.

MosesTJ 06-08-2013 04:51 AM

Seems weird it's boiling over but temp gauge is not that high.
1. Check to see how fast you fan is spinning.
2. Check to see if all your hoses coming from rad are getting hot.
3. Change thermostat.
Obviously you need a new one being its cracked. Also, have you been mudding or had the front end submerged in water lately?

johnny102393 06-08-2013 05:17 AM

No mud or sumerging in water it cracked today as far as i can tell it overheated going down the highway with the ac on im going to replace the thermostat and sending unit later today but i know i need a new rad now :(((((

johnny102393 06-08-2013 05:18 AM

Quote:

Originally Posted by MosesTJ (Post 3838431)
Seems weird it's boiling over but temp gauge is not that high.
1. Check to see how fast you fan is spinning.
2. Check to see if all your hoses coming from rad are getting hot.
3. Change thermostat.
Obviously you need a new one being its cracked. Also, have you been mudding or had the front end submerged in water lately?

The fan is fine maby i need a waterpump

johnny102393 06-09-2013 01:19 AM

Bump

Dieselholic 06-09-2013 06:30 AM

thermostat locked up. My old bronco did the same thing. Once it locked up the water pump built to much pressure and cracked the radiator.

johnny102393 06-09-2013 01:36 PM

Thanks i should be replacing the thermostat today along with the oil sending unit

johnny102393 11-29-2013 10:13 AM

Sorry for not following up until now but i replaced the thermostat waterpump radiatior and hoses. I bought a brass copper radiator and it keeps the jeep at about 205ish works really well


All times are GMT -5. The time now is 02:46 PM.