Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   YJ Tech Forum (http://www.wranglerforum.com/f218/)
-   -   Engine shut off after Seafoam. Won't start (http://www.wranglerforum.com/f218/engine-shut-off-after-seafoam-wont-start-248493.html)

Jeep0321 06-10-2013 07:36 PM

Engine shut off after Seafoam. Won't start
 
Ok so I did a partial treatment with seafoam. Only the gas tank and vaccum line. Let it sit the required time. Started up fine and ran it for about 25 min. Finished smoking and let it sit for about 45 min. Came out and it started up fine. About 10 min down the road, it sputtered and died. Now it'll crank up but won't start. Pulled the plugs and changed them. Still wont turn over. I don't hear a hum or anything when I first turn the key. Fuel pump you think?

Garyk 06-10-2013 07:41 PM

Check your fuel filter,seafoam loosens a lot of crud..

Jeep0321 06-10-2013 07:48 PM

Ok. I was thinking fuel filter or fuel system. I drained the pressure from the fuel rail and it hissed a bit and threw some fuel. Then tried to start it again a few times. This time, no fuel or air drains from the valve. I'll check the fuel filter and if that doesn't work, the pump.

Jeep0321 06-12-2013 02:36 PM

Before I started tearing into the fuel system and dropping the tank, I tried starting it with the help of starter fluid. Still wouldn't turn over. I'm beginning to think that fuel isn't the problem. Might be a spark issue. Ideas?

91_YJ 06-12-2013 02:47 PM

you do or don't have fuel at the rail?
are you getting a spark?

Jeep0321 06-12-2013 03:09 PM

I test the schrader valve and it drains some fuel. If i was getting no fuel, wouldn't it still start to turn over with the starter fluid?

Jeep0321 06-12-2013 04:11 PM

Just took the filter off and gas was flowing through it. I'm definitely thinking spark or ECM.

Garyk 06-13-2013 04:14 PM

If the pump is on and you hit the test vlave it should do more than drain, it should squirt out...it should have pressure.

Jeep0321 06-13-2013 09:20 PM

Ok I'll replace the pump. Hopefully that's it.

Michigan jeeper 06-13-2013 09:30 PM

Check the coil too

Jeep0321 06-13-2013 11:20 PM

I'm going to change the pump, check the CPS and the coil. After that, I'm stumped. Shouldn't it kind of start with starter fluid in the air box if it was getting a spark? Even with no fuel, the starter fluid should get it to kinda start.

jokerchief462 06-13-2013 11:28 PM

Yes it should but you may have more than one problem. From what I have read fuel supply at the rail is low and since it won't fire off on starting fluid you may have a spark problem.

So yes to your plan and yes if it had spark it should have fired off.

CMike357 06-14-2013 01:43 PM

Fuel, Air, & Spark. Fuel pressure regulator, maybe? I know it can be frustrating.

Jeep0321 06-16-2013 03:44 AM

It's very frustrating. I'm a cop and I work night watch and try and sleep during the day. No time to do any of the work.

bubbadah 06-16-2013 10:53 AM

I took a loaner pressure rest gauge from Auto Zone to test the pressure at the fuel gauge. It was super easy to do, took about five minutes.

tyborbogdan 06-16-2013 01:28 PM

this happened to me, i just cleaned the plugs and it started.
blew out the blackest grossest exhaust ive ever seen for about 2 minutes.

Arm67ando 06-16-2013 11:41 PM

I know it can be frustrating.http://www.usa-nfl-houstontexans.info/28.jpg

Jeep0321 06-22-2013 10:18 AM

Well, I changed all the parts. Cps, coil, plugs, distributor cap, rotor, fuel filter. All of it. Still no spark. I did, however, notice that the check engine light does not come on when I click the power on. Word has it that this is a clue that the ECM is bad. Ordered a factory new one for $289. Should be here Monday. Hope that does it.

Jeep0321 06-24-2013 06:17 PM

New ECM. Still not starting.

WICruiser 06-24-2013 07:44 PM

It sounds like you changed all the relavent parts of the igntion system but still have no spark so you need to regroup and check both what you did and what the result was.. For example how are you confirming that you do not have spark? Can you do diagnostics on the ignition portion of the ECM?


All times are GMT -5. The time now is 05:41 AM.