Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   JK General Discussion Forum (http://www.wranglerforum.com/f274/)
-   -   Leaky Trektop NX (http://www.wranglerforum.com/f274/leaky-trektop-nx-249209.html)

RescueJK08 06-13-2013 07:50 PM

Leaky Trektop NX
 
I installed my Trektop NX yesterday afternoon it's leaking already! The zipper seams are leaking very slightly and with the non-stop rain over the past day it's created a little puddle.
The main leak is from the zipper seam near the tailgate bar. At first I thought it was something I hadn't installed correctly, but after sitting in the trunk watching it with a flashlight I could actually see the water droplets seeping in through the seam.

I want to know if anyone else who has the Trektop has had this issue and what you did to fix it?

Hillvol16 06-14-2013 05:26 PM

I just learned a very valuable lesson as a first time Jeep owner. The Trektop NX does not fit flush and will actually "flap" in the wind. So I guess when it rains, I get wet? I wish I would have known this before I dropped the $600 as this was going to be my summer top?!?

jgjg76 06-14-2013 05:28 PM

So far so good for me and it's my second year with the top. Its also been raining here a lot so far this year.

Hillvol16 06-14-2013 05:32 PM

Can you see light above the doors when the wind blows? Can you fit your hand over the top of the bar and under the top?

repauli1 06-14-2013 08:43 PM

Quote:

Originally Posted by Hillvol16
Can you see light above the doors when the wind blows? Can you fit your hand over the top of the bar and under the top?

Your top is either defective or not installed properly, using mine year round, no leaks, and quiet compared to factory softop that leaked like a hurricane. Mine in a JKU.

Hillvol16 06-14-2013 10:31 PM

Can someone post pictures of how it should look above the doors? Please and thanks you. Is there a seal or are the flaps above the door supposed to have a space..if winds blows from the side I can see out above bothe doors. 4 door JKU

Hillvol16 06-14-2013 11:32 PM

Quote:

Originally Posted by repauli1 (Post 3861920)
Your top is either defective or not installed properly, using mine year round, no leaks, and quiet compared to factory softop that leaked like a hurricane. Mine in a JKU.

I will post some pics tomorrow but I can literally stick my hand above the door and reach straight outside.

Hillvol16 06-14-2013 11:37 PM

Pics
 
1 Attachment(s)
Can you see how the top of the flap doesn't come over the door.....

Hillvol16 06-14-2013 11:44 PM

1 Attachment(s)
See the light zooming from above the door jam....is this correct? No seal at all?

Hillvol16 06-14-2013 11:46 PM

1 Attachment(s)
Again...this is sitting in the driver seat looking out at the door....see the light

Hillvol16 06-14-2013 11:47 PM

The guy at the Off Road store stated that these don't seal and yet all of the pics I have see on here show the top going over the bar. Sorry for so many posts but I need to know if I should be pissed. It wasn't cheap having them install this top.

Hillvol16 06-14-2013 11:49 PM

1 Attachment(s)
I'll take some outside looking in pics in the morning and thanks for your help.

AMilton 06-15-2013 01:40 AM

I installed mine a couple of weeks ago and it fits perfect with no leaks.
It looks like the top is not setting in the channels of the door surrounds.
The only thing I can think of that would cause that is the cables not being attached.
Check to make sure the cables are attached to the bracket at the rear of the top at the top rear corner of the back door. There should be a spring on the end of the cable that attaches to the bracket.

Hillvol16 06-15-2013 07:53 AM

I will take a look and thanks. So this isn't what the top is supposed to look like.

Das_Jeep 06-15-2013 08:06 AM

I put mine on about a month ago, and it went thru some serious rain storms lately...both driving and parked...no leaks :thumb:

And I do not see any light above the door either...sounds like the top is not sitting down inside the door surround...or possibly the cables are not hooked properly as mentioned before.

Hillvol16 06-15-2013 08:08 AM

1 Attachment(s)
See the separation and the wire connection is really loose.

jp2611 06-15-2013 08:15 AM

I will be the first to say IDK...but I have the frameless for my TJ and it is quieter than the stock or any other top I have ran...IMO something is not "right"....I have never seen a Bestop top look like that after correct install.

Hillvol16 06-15-2013 08:33 AM

Sorry about the upside down picture. Are we all in agreement that this isn't right? If that is the case than I am livid since I spent over $200 to have it "professionally" installed.

Das_Jeep 06-15-2013 08:36 AM

Quote:

Originally Posted by Hillvol16 (Post 3863021)
Sorry about the upside down picture. Are we all in agreement that this isn't right? If that is the case than I am livid since I spent over $200 to have it "professionally" installed.

Yes..I agree that it does not look right

Das_Jeep 06-15-2013 08:40 AM

1 Attachment(s)
Quote:

Originally Posted by Das_Jeep (Post 3863027)

Yes..I agree that it does not look right

Here is a pic looking from front to rear..sending from my phone so hope it attaches

Attachment 261664

Hillvol16 06-15-2013 08:55 AM

Quote:

Originally Posted by Das_Jeep (Post 3863035)
Here is a pic looking from front to rear..sending from my phone so hope it attaches

Attachment 261664

It looks like yours actually folds over into the rain channel. Whereas mine just barely comes to the door jam.

Hillvol16 06-15-2013 08:56 AM

Thanks for the pic Das!

Hillvol16 06-15-2013 09:04 AM

1 Attachment(s)
More pics.

Hillvol16 06-15-2013 10:29 AM

I checked and the wire does run through the side but it is extremely loose.

stryke-force 06-15-2013 12:19 PM

Who was your "professional" installer? Doesn't seem right to me.

kEat 06-15-2013 01:20 PM

Quote:

Originally Posted by Hillvol16 (Post 3863279)
I checked and the wire does run through the side but it is extremely loose.

There are tighter settings for that cable, but I don't think that will help your situation. There is something very odd going on with your top, almost like there is too much material at the front. When latched down it should sit right in the rain channels of the door surrounds.

Hillvol16 06-15-2013 01:52 PM

Quote:

Originally Posted by stryke-force (Post 3863520)
Who was your "professional" installer? Doesn't seem right to me.

I took it to Essentially Off Road in Murfreesboro, TN.

kEat 06-15-2013 02:03 PM

Are the "arms" that connect into the door surrounds fully locked into place? And it's latched at the front, yes? I know it sounds like a silly question, but now that I think of it, that is exactly what the back of my top looks like when it's unlatched or the arms aren't properly connected to the door surround.

ThermalFZ6 06-15-2013 03:32 PM

Check the front and rear bows to make sure they are seated right and check the tube that goes across the middle in front of the sound bar. Something is not seated right. I have one of these tops too and it is perfect, no leaks and the top should sit in the channels along the sides like Das_Jeep posted.

matthew87 06-15-2013 05:01 PM

I say go the quadratec's NX page to get the instructions and start over.


All times are GMT -5. The time now is 02:18 AM.