Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   CJ Tech Forum (http://www.wranglerforum.com/f258/)
-   -   Power drain (http://www.wranglerforum.com/f258/power-drain-249357.html)

02tj-clayton 06-14-2013 04:20 PM

Power drain
 
My 74 will not turn over at all

I've charged the battery and still nothing

bc3_Jeep 06-14-2013 06:04 PM

I would ALWAYS suspect poor connections in a situation like this. Clean battery terminals AND inside the clamps.......

Remove and clean contacts on starter and relay. Dremel tool wire brush works WAY good for this.

Also clean ANY ground connections to frame and engine block.

02tj-clayton 06-15-2013 12:15 PM

I just put new clamps on and I had the battery charging all night
It clicked once then nothing

gcaughron 06-16-2013 10:45 AM

Check the starter relay. You can jump across the terminals to see if it is bad, you might see some sparks but don't be scared. If it's bad it's a cheap part to replace.

02tj-clayton 06-19-2013 03:38 PM

I bought a new starter solnoid and still nothing

harleydragon 06-20-2013 05:22 PM

Quote:

Originally Posted by 02tj-clayton (Post 3863507)
I just put new clamps on and I had the battery charging all night
It clicked once then nothing

sounds like a bad connection..even new clamps need the connecting surfaced sanded to get a good connection..while you are at it , sand or wire brush the battery posts

02tj-clayton 06-20-2013 11:10 PM

I just put new cables on and still nothing

The terminals are clean as a whistle

02tj-clayton 06-21-2013 11:26 PM

Got it to turn over but it's grounding outbsomewhere


All times are GMT -5. The time now is 03:32 PM.