Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   JK General Discussion Forum (http://www.wranglerforum.com/f274/)
-   -   430n Uconnect (http://www.wranglerforum.com/f274/430n-uconnect-250765.html)

IORRichie 06-21-2013 06:27 AM

430n Uconnect
 
Ok so I need some data.. lol

I have a 430n unit with connectivity group and uconnect etc. And when I recieve a text message it can never give me a name or a phone number over the radio.

So the question to peeps with the same headunit, when you receive a text or a call for that matter. When Uconnect announces it do you get more then "you have recieved a text message from no number available".

Let me know how yours functions. Does mine need more set up?

xsdbs 06-21-2013 09:16 AM

You are on a CDMA network, (Sprint or Verizon) correct? This is a network related issue. When the text comes thru, the network doesn't send a (+) in the beginning of the number so when the phone sends the BT message about the incoming text message, the phone doesn't send the correct information to Uconnect for it to tell you who sent the message.

No caller id with incoming text message on Verizon network

| bt_map: tell sms_ta00:09:09.420| bt_map: tell sms_task about new message timestamp:()<CR><LF>
00:09:09.420| bt_map: sendDL_State: send message 402 to sms-task<CR><LF>
00:09:09.420| Client: MAP Pull MESSAGE operation complete.<LF><CR>
00:09:09.420| bt_map: mapEventReceived (3) <LF><CR>
00:09:09.420| bt_map: EventComplete Received<CR><LF>
00:09:09.420| bt_map: mapContinueDownload but messageBuffer locked, try later<LF><CR>
00:09:09.420| SMS task: BT_EVENT_NEW_SMS_MAP<LF><CR>
00:09:09.420| SMS Task: WARNING!!! Phonenumber start symbol + or : not detected !!!<LF><CR>

<in the above section, you see that the phone does not send Uconnect the ID for the incoming text message, this is why Uconnect resplies with ‘no number available>
00:09:09.420| SMS task: WARNING: Unknown Timestamp Format <LF><CR>
00:09:09.437| TTS_FRONTEND: TTS_PROCESS_BUFFER_INTO_FILE_REQ - '10000006.pcm' C = 0 'Testing for incoming names when texted'<LF><CR>
00:09:09.437| TTS_FRONTEND: TTS_PROCESS_BUFFER_INTO_FILE_REQ unicode strlen[38]<LF><CR>
00:09:09.437| bt_map:handleBTMainMessage unlock buffer BT_EVENT_NEW_SMS_MAP_OK<CR><LF>
00:09:09.437| bt_map: mapContinueDownload<LF><CR>
00:09:09.437| bt_map: mapContinueDownload messageQueue done<LF><CR>
00:09:09.437| TTS_BACKEND: TTS_PROCESS_BUFFER_INTO_FILE_REQ received<LF><CR>
00:09:09.454| TTS_BACKEND: Do the text to speech Processing <LF><CR>
00:09:09.454| TTS_BACKEND: call,inputstring: <ESC>_ <LF><CR>
00:09:09.454| TTS_BACKEND: call,inputstringlenth: 100 <LF><CR>
00:09:09.454| TTS_BACKEND: VAUTO_MSG_BEGINPROCESS<LF><CR>


Caller id with incoming call on Verizon network
00:15:17.987| car_kit.c: 2 reporting HF_EVENT_CALL_STATE: Line 1: State: 255<LF><CR>
00:15:17.987| car_kit.c: Call State = Incoming Call, Line = 1: <LF><CR>
00:15:19.204| car_kit.c: AG reported AT data: RING, Len: 4 <LF><CR>
00:15:19.204| BT Task: AG reported AT data: Device: 0 Data: RING, Length: 4 <LF><CR>
00:15:19.220| BT Task: reported 'caller ID' event - ID: 2486131234 line - 0<LF><CR>
00:15:19.220| RADIO: Set radio display 145 UNKNOWN<LF><CR>
00:15:19.220| Menu_convertMessage: BT_EVENT_CALL_ID_IND - call states: active 0 held 0 <LF><CR>
00:15:19.220| Menu_convertMessage: BT_EVENT_CALL_ID_IND - got number

<In the above section, you see that the phone sent Uconnect the ID for the incoming caller, this lets Uconnect search the stored phonebook to match a name to the number. Then Uconnect will display the name of the incoming caller.>







Quote:

Originally Posted by IORRichie (Post 3884641)
Ok so I need some data.. lol

I have a 430n unit with connectivity group and uconnect etc. And when I recieve a text message it can never give me a name or a phone number over the radio.

So the question to peeps with the same headunit, when you receive a text or a call for that matter. When Uconnect announces it do you get more then "you have recieved a text message from no number available".

Let me know how yours functions. Does mine need more set up?


IORRichie 06-21-2013 09:44 AM

Quote:

Originally Posted by xsdbs (Post 3884933)
You are on a CDMA network, (Sprint or Verizon) correct? This is a network related issue. When the text comes thru, the network doesn't send a (+) in the beginning of the number so when the phone sends the BT message about the incoming text message, the phone doesn't send the correct information to Uconnect for it to tell you who sent the message.

No caller id with incoming text message on Verizon network

| bt_map: tell sms_ta00:09:09.420| bt_map: tell sms_task about new message timestamp:()<CR><LF>
00:09:09.420| bt_map: sendDL_State: send message 402 to sms-task<CR><LF>
00:09:09.420| Client: MAP Pull MESSAGE operation complete.<LF><CR>
00:09:09.420| bt_map: mapEventReceived (3) <LF><CR>
00:09:09.420| bt_map: EventComplete Received<CR><LF>
00:09:09.420| bt_map: mapContinueDownload but messageBuffer locked, try later<LF><CR>
00:09:09.420| SMS task: BT_EVENT_NEW_SMS_MAP<LF><CR>
00:09:09.420| SMS Task: WARNING!!! Phonenumber start symbol + or : not detected !!!<LF><CR>

<in the above section, you see that the phone does not send Uconnect the ID for the incoming text message, this is why Uconnect resplies with ‘no number available>
00:09:09.420| SMS task: WARNING: Unknown Timestamp Format <LF><CR>
00:09:09.437| TTS_FRONTEND: TTS_PROCESS_BUFFER_INTO_FILE_REQ - '10000006.pcm' C = 0 'Testing for incoming names when texted'<LF><CR>
00:09:09.437| TTS_FRONTEND: TTS_PROCESS_BUFFER_INTO_FILE_REQ unicode strlen[38]<LF><CR>
00:09:09.437| bt_map:handleBTMainMessage unlock buffer BT_EVENT_NEW_SMS_MAP_OK<CR><LF>
00:09:09.437| bt_map: mapContinueDownload<LF><CR>
00:09:09.437| bt_map: mapContinueDownload messageQueue done<LF><CR>
00:09:09.437| TTS_BACKEND: TTS_PROCESS_BUFFER_INTO_FILE_REQ received<LF><CR>
00:09:09.454| TTS_BACKEND: Do the text to speech Processing <LF><CR>
00:09:09.454| TTS_BACKEND: call,inputstring: <ESC>_ <LF><CR>
00:09:09.454| TTS_BACKEND: call,inputstringlenth: 100 <LF><CR>
00:09:09.454| TTS_BACKEND: VAUTO_MSG_BEGINPROCESS<LF><CR>


Caller id with incoming call on Verizon network
00:15:17.987| car_kit.c: 2 reporting HF_EVENT_CALL_STATE: Line 1: State: 255<LF><CR>
00:15:17.987| car_kit.c: Call State = Incoming Call, Line = 1: <LF><CR>
00:15:19.204| car_kit.c: AG reported AT data: RING, Len: 4 <LF><CR>
00:15:19.204| BT Task: AG reported AT data: Device: 0 Data: RING, Length: 4 <LF><CR>
00:15:19.220| BT Task: reported 'caller ID' event - ID: 2486131234 line - 0<LF><CR>
00:15:19.220| RADIO: Set radio display 145 UNKNOWN<LF><CR>
00:15:19.220| Menu_convertMessage: BT_EVENT_CALL_ID_IND - call states: active 0 held 0 <LF><CR>
00:15:19.220| Menu_convertMessage: BT_EVENT_CALL_ID_IND - got number

<In the above section, you see that the phone sent Uconnect the ID for the incoming caller, this lets Uconnect search the stored phonebook to match a name to the number. Then Uconnect will display the name of the incoming caller.>


I'm in Canada on the telus network.... but I assume the reason would be the same..

xsdbs 06-21-2013 11:46 AM

Correct. The only phones that I have seen that work correct on incoming messages are the ones with SIM cards (ATT & T-mobile here in the US).




Quote:

Originally Posted by IORRichie (Post 3885000)
I'm in Canada on the telus network.... but I assume the reason would be the same..


IORRichie 06-21-2013 02:24 PM

Quote:

Originally Posted by xsdbs (Post 3885422)
Correct. The only phones that I have seen that work correct on incoming messages are the ones with SIM cards (ATT & T-mobile here in the US).

My phone does have a sim card...... all new telus phones do...

xsdbs 06-24-2013 10:54 AM

But is that SIM card for the LTE / 4G network. You didn't mention what model your phone is, but I'll still bet it's a CDMA phone.




Quote:

Originally Posted by IORRichie (Post 3885932)
My phone does have a sim card...... all new telus phones do...


RacecarBMW 06-24-2013 02:23 PM

Nope I'm sure IORRichie's phone is a GSM device all our phone networks here in Canada are 100% GSM.

mike1158 06-24-2013 03:53 PM

Quote:

Originally Posted by xsdbs (Post 3885422)
Correct. The only phones that I have seen that work correct on incoming messages are the ones with SIM cards (ATT & T-mobile here in the US).

makes GREAT sense that they have a system that doesn't work with Verizon...the LARGEST mobile carrirer in the U.S. thats AWESOME :facepalm:

IORRichie 06-24-2013 09:21 PM

its a samsung galaxy note 2. telus network which is gsm.

still can't figure it out...

xsdbs 06-25-2013 09:15 AM

Ok, so your phone is a GSM phone. As I mentioned earlier that there are also SIM cards in the CDMA phones that are 4G & LTE phones. But you have found that it is for sure a GSM network.
So now we need to get past that part. Is your phonebook downloaded? When you have an incoming call, does Uconnect say (EX) "incoming call from Dolphin Lover"? (or any of your contacts).
If you press and release the Uconnect phone button and say "text message, send 4", how does Uconnect respond?







Quote:

Originally Posted by IORRichie (Post 3895801)
its a samsung galaxy note 2. telus network which is gsm.

still can't figure it out...


CoreyZ 06-25-2013 09:19 AM

I was on T-Mobile when I had my UConnect and it never worked right either.
It also was intermittent... One day it would say the callers name, other times just the phone number...
When I had Sprint... same thing.
Always a Galaxy S3, both stock ROM and custom ones.

cueball13 06-25-2013 09:27 AM

I can't send or receive in my durango with a 430. But that Is because I am stuck in the 'Apple vs the world' battle of compatibility.

I have an iphone5 and am on AT&T

Or am I doing something wrong?

xsdbs 06-25-2013 10:21 AM

Nope, you're not doing anything wrong. This is an issue where Apple thinks that they are the almighty and that everyone should conform to them. I find it kind of funny that they are touted as the best but yet have to constantly come out with updates. Several times they have come out with an update right after the release of their product.
Apple doesn't support the same use of SW wording that others do, so they don't send any incoming message notifications to Uconnect (and some others). They also want you to be able to reply to messages by using SIRI instead of using the 20 generic reply messages that are stored in Uconnect and other car kits. The problem there is that SIRI, visual voice mail and voice memos are not supported by Uconnect because of the way Apple handles an incoming call when in one of these features.
So have Apple, have no Bluetooth texting.




Quote:

Originally Posted by cueball13 (Post 3897205)
I can't send or receive in my durango with a 430. But that Is because I am stuck in the 'Apple vs the world' battle of compatibility.

I have an iphone5 and am on AT&T

Or am I doing something wrong?


xsdbs 06-25-2013 10:23 AM

Well thanks for that information. I didn't know that. So now we need to figure out why the SMS feature isn't working. Here in the US, it's usually as I had mentioned with CDMA vs GSM.


Quote:

Originally Posted by RacecarBMW (Post 3894464)
Nope I'm sure IORRichie's phone is a GSM device all our phone networks here in Canada are 100% GSM.


IORRichie 06-25-2013 10:37 AM

I can't recall the last phone call I had what the radio said.. almost postitive it said no number available.

Phonebook isn't downloaded but I've added a few selected contacts I text frequently. Yet still no number available for them for a text. Not sure about a phone call

IORRichie 06-25-2013 10:39 AM

Oh also yes when I recieve a text I can press the uconnect button say text and either read text or send text.

CoreyZ 06-25-2013 11:55 AM

I was able to read them through the uconnect.... but never send them

xsdbs 06-25-2013 12:38 PM

When you say that you added some contacts, do you mean that you manually put them into Uconnect's phonebook or that you added them to the phone? How many contacts did you add?
Can you tell me the model # of the phone? I know you said it's the NOTE2 but there are a few different models of it. Thanks



Quote:

Originally Posted by IORRichie (Post 3897413)
I can't recall the last phone call I had what the radio said.. almost postitive it said no number available.

Phonebook isn't downloaded but I've added a few selected contacts I text frequently. Yet still no number available for them for a text. Not sure about a phone call


IORRichie 06-25-2013 01:51 PM

I manually added some to the phonebook of the uconnect.

Model is sgh-1317m

mike1158 06-25-2013 01:59 PM

Quote:

Originally Posted by xsdbs (Post 3885422)
Correct. The only phones that I have seen that work correct on incoming messages are the ones with SIM cards (ATT & T-mobile here in the US).

makes GREAT sense that they have a system that doesn't work with Verizon...the LARGEST mobile carrirer in the U.S. thats AWESOME :facepalm:

xsdbs 06-26-2013 08:54 AM

Mike,
What you're not hearing is that the issue is with the network, not Uconnect. According to BT specs the number has to be sent in a particular message, if the message is not seen the way that it's being looked for then there will be a failure.



Quote:

Originally Posted by mike1158 (Post 3898016)
makes GREAT sense that they have a system that doesn't work with Verizon...the LARGEST mobile carrirer in the U.S. thats AWESOME :facepalm:



All times are GMT -5. The time now is 07:00 AM.