Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ Tech Forum (http://www.wranglerforum.com/f210/)
-   -   Engine troubles (http://www.wranglerforum.com/f210/engine-troubles-252189.html)

Seanrugby11 06-27-2013 06:57 PM

Engine troubles
 
2 Attachment(s)
Hi guys,

I'm having some issues with my 1998 Sahara 4.0L. It started stalling out on me for no apparent reason. I have to hold the throttle while some one turns the key to start her back up. Then I felt it continue to accelerate when I released the pedal. The second I stopped the jeep sure enough it stalled out. Now the check engine light is on. Haven't gotten a chance to go to autozone yet to get the codes. Side note found a hose just laying out by the passenger side that leads to the back. Any ideas?

This is my first jeep and my baby. Please help me get her running by the fourth so I can go topless and enjoy the day!!?!

Thanks guys!

jeepwayoflife 06-28-2013 02:43 AM

Welcome! Im sorry I can't help much with the engine, but for that tube, where exactly is it located and can you post a more close up picture of the end? If that's under the gas cap area it could be the rear axle breather tube. They are normally attached inside but yours could have simply come off.

Seanrugby11 06-30-2013 09:26 PM

2 Attachment(s)
Ummm so here's a pic of the Ned of the tube. Sorry I haven't replied for a while. Was in Denver all weekend. But I left it sitting for about a week now and now the light is off and she runs fine around the block. Any ideas?

Thanks!!

Seanrugby11 06-30-2013 09:27 PM

It's front passenger side right behind the wheel. It feeds to the back

Seanrugby11 07-02-2013 09:56 PM

So it's working now. Idk why, maybe bad gas. Thanks!

jherrington 07-02-2013 10:31 PM

Sounded like one of two things.

Throttle position sensor

or

Idle air control valve.

One of them may have just been stuck or dirty, keeping it from functioning correctly.


All times are GMT -5. The time now is 05:38 AM.