Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   Communications and Electronics (http://www.wranglerforum.com/f40/)
-   -   Automatic Shutdown Relay Fuse Issues (http://www.wranglerforum.com/f40/automatic-shutdown-relay-fuse-issues-252242.html)

JasenBragg 06-27-2013 11:47 PM

Automatic Shutdown Relay Fuse Issues
 
Well. I have a 2012 Wrangler Sahara 4dr and this past week I had to tow my jeep into a dealership in Texarkana. I was driving 45 mph and not trying to gun the rpms. I had total shutdown but was able to get off the road. The dealership hooked it up and told me that my ASD 25 amp fuse had blown but couldn't figure out why. My jeep ran okay for much of the day but by night it blew another fuse as I accelerated from a green light. I replaced it with a 30 amp fuse but fear that is too much for a burn out but i wanted to make sure i got home. I drove back home (an hour drive up and down hills) and it seemed to always want to ramp up the RPMs suddenly. I would love to know if anyone else has had this kinda issue? I have less than 20,000 miles on my jeep.

I have now had three fuses blow and two tows to dealerships because i couldnt keep a good fuse. I hope someone can please help me point out the direction the dealership needs to be looking for. This is getting frustrating. It seems to blow a fuse when I hit any type of bump in the road. No electrical mods were made except my warm winch which was installed at the dealership.

JasenBragg@gmail.com


All times are GMT -5. The time now is 12:23 AM.