Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ Tech Forum (http://www.wranglerforum.com/f210/)
-   -   Need some transmission advice!! (http://www.wranglerforum.com/f210/need-some-transmission-advice-252593.html)

04BlueTJ 06-29-2013 07:58 PM

Need some transmission advice!!
 
I have a 04 Sport with 4.0/auto. When I purchased I knew the transmission was going to need to be rebuilt. It was slipping from 3rd to 4th really bad. Anyways, rebuilt transmission, they found the 2/4 clutch pack destroyed.

Well, it seems to be doing it again, but not as bad. When it shifts from 3rd to 4th, it revs then shifts. Almost like I have a stick and I rev the engine. Its only raises about 100-200 rpms, but it bothers me. I wanted to know if this is normal on the TJs.
Just a little background:

Rebuilt transmission
New convertor
New valve body and electronics
New TCM
New TPS
New EATX relay (transmission control relay)

If I turn off overdrive, the 3rd to 4th shift is perfect

The only thing I can think of is the PCM. Just wondering if I am missing something?

Thanks in advance.

Hiatus83 06-29-2013 10:14 PM

might be a shift selonoid my buddys xj was doing this, but his symptoms clearly point to this issue, does your car do it all the time or just after it is warmed up like after maybe 20-30 mins of driving or right off the bat it is doing this

04BlueTJ 06-30-2013 12:02 AM

I would say once maybe after about 5-10 minutes. I can barely feel it when I first start driving, but maybe becuase I am really paying attention.

The did replace the valve body, isn't that where the shift selonoid is located?

Hiatus83 06-30-2013 08:03 AM

the shift selonoids are located in the transmission pan behind the transmission filter, check out this link its a detailed breakdown of the repair. pretty sure this is your problem if it runs fine until it warms up, then is acting like its slipping like a clutch

AW4 Solenoid replacement write-up (no 56k). - JeepForum.com

flflash 06-30-2013 08:21 AM

No warranty on the repair work done?

04BlueTJ 06-30-2013 11:22 AM

Hiatus 83, thanks for the link, I know that is for an AW4, I take it that it is almost the same for a 42RLE? I have an exploded parts diagram and it show 3 or 4 solenoids. I will take a look and see what I can find out. Thanks again.

flflash, yes it has a warranty. I am just trying to give something to go on. The only thing I will have to pay is for parts, no labor.


All times are GMT -5. The time now is 06:01 AM.