Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ Tech Forum (http://www.wranglerforum.com/f210/)
-   -   Right brake light problem! (http://www.wranglerforum.com/f210/right-brake-light-problem-253885.html)

jeepr1106 07-05-2013 10:09 PM

Right brake light problem!
 
When i press my brakes in my 04 rubicon my right light will not turn on, but when parking lights are on the light will turn on but will not get bright when brake is pressed.

JimsJeep 07-05-2013 10:21 PM

Might be as simple as a bit of corrosion in the socket. Best place to start.

jeepr1106 07-05-2013 10:46 PM

they are led lights in wired in Parallel

Atthehop 07-06-2013 07:14 AM

Check your grounds, tail lamps ground with the mounting screws.

Redrider94 07-06-2013 07:24 AM

Does your right turn signal work when you turn it on? If your turn signal works then I'd say that you may have a problem with your turn signal switch. If turn signal is not working them I'd look for a break in the brake light wiring.

jeepr1106 07-06-2013 05:07 PM

I figured it out, previous owner removed third brake light and left the wires open and not completing the circuit. i just put a load between the + and - and it fixed the problem

freeskier 07-06-2013 07:29 PM

10 Attachment(s)
Quote:

Originally Posted by jeepr1106 (Post 3933392)
I figured it out, previous owner removed third brake light and left the wires open and not completing the circuit. i just put a load between the + and - and it fixed the problem

Not sure how this fixed the problem, can't remember the last time I had a third brake light and that certainly hasn't given me problems.

Your issue sounded like a bad ground.

Your wirings seems funky.

jeepr1106 08-05-2013 02:46 AM

Ok problem is back

jeepr1106 08-05-2013 02:55 AM

2 Attachment(s)
Attachment 281799



Attachment 281798

This is what it looks like

T2000J 08-05-2013 05:55 AM

Quote:

Originally Posted by jeepr1106 (Post 4040661)

This is what it looks like

I'd say ground problem them cages tend to be a PITA . My first Tj had them they worked then didn't work . Take a wire hook it to your bumper and put the other end to your light .

Water Dog 08-05-2013 09:28 AM

Quote:

Originally Posted by redrider94 (Post 3932126)
does your right turn signal work when you turn it on?

x2..??

freeskier 08-05-2013 10:31 AM

10 Attachment(s)
Quote:

Originally Posted by T2000J (Post 4040803)

I'd say ground problem them cages tend to be a PITA . My first Tj had them they worked then didn't work . Take a wire hook it to your bumper and put the other end to your light .

They are LEDs which means they are no longer grounded through the mounts. Looks like bad wiring job or multi function switch.

OP does the right blinker work?

jeepr1106 08-05-2013 01:13 PM

Huh

Water Dog 08-05-2013 02:31 PM

Quote:

Originally Posted by jeepr1106 (Post 4042040)
Huh

Huh what? Does the right turn signal work???? :whistling:

jeepr1106 08-05-2013 03:07 PM

No it is also dim, but when I turn on parking lights it gets brighter

Water Dog 08-05-2013 03:31 PM

I think Freeskier is right....probably miswired.

jeepr1106 08-05-2013 04:06 PM

How is it supposed to be wired, there is a black, green and red wire coming from the light

T2000J 08-05-2013 04:57 PM

Past few LEDs had different pigtails on them YOUR colors I can't say but the jeep Harness is so :
Purple/black = reverse light
Black/yellow = taillight
Green /red = (left) turn/stop
Brown/ red = (right) turn/stop

jeepr1106 08-05-2013 05:21 PM

The wiring is good. Idk what the problem is

Water Dog 08-05-2013 06:34 PM

I would try disconnecting the led's and use a test light to test the jeep wiring. If that works, then you know it's in the led circuitry or a ground, if it doesn't work with a standard test light, then it's probably the multifuntion switch. (You'll have to check it there.)

freeskier 08-05-2013 06:57 PM

10 Attachment(s)
Quote:

Originally Posted by Water Dog (Post 4043282)
I would try disconnecting the led's and use a test light to test the jeep wiring. If that works, then you know it's in the led circuitry or a ground, if it doesn't work with a standard test light, then it's probably the multifuntion switch. (You'll have to check it there.)

Yup, if it's not the lights or wiring the multifunction switch is the next likeliest thing to check. Everything goes through it and it doesn't take much fore the traces in there to short with each other. I've had mine open 3 or 4 times now to fix it.

jeepr1106 08-05-2013 07:15 PM

Were is it

Water Dog 08-05-2013 07:31 PM

It's the turn signal switch on the steering column

jeepr1106 08-05-2013 07:46 PM

Could I get a picture?

Water Dog 08-05-2013 08:05 PM

Quote:

Originally Posted by jeepr1106 (Post 4043644)
Could I get a picture?

The only picture I have is the one off a "99", yours probably has the headlights on it as well.

jeepr1106 08-05-2013 09:02 PM

Ok so, when the parking lights are on the light works. When harzards are on, right turn signal and brakes are pressed its dim

jeepr1106 08-05-2013 09:50 PM

What do I do when I open it

jeepr1106 08-05-2013 10:42 PM

I check all the pins they look good

bigal66 08-09-2013 11:59 PM

Exactly the same thing happened to me when I put LED bulbs in my TJ. Don't want to sound too technical, but you have to install 2 blocking diodes for the rear lights and 2 for the front turn signal/park lights. Also, since I didn't want to use load resistors to force the blinkers to work, I swapped out the blinker module for an electronic one made for LEDs.

jeepr1106 08-10-2013 12:16 AM

So if I can replace that relay


All times are GMT -5. The time now is 05:09 PM.