Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   JK General Discussion Forum (http://www.wranglerforum.com/f274/)
-   -   brakes make squeak sound only at a slow stop (http://www.wranglerforum.com/f274/brakes-make-squeak-sound-only-at-a-slow-stop-254110.html)

tg14226 07-07-2013 07:16 AM

brakes make squeak sound only at a slow stop
 
I have a 2013 4 door Sahara. It has only 1,200 miles on it and recently I noticed that when I apply pressure at a normal brake (stopping at faster speeds) all is good and normal. However, when I'm creeping up to a stop sign, for example, and apply pressure to the brakes there is a odd squeaky/clunky noise that only occurs, not as I'm braking but as I apply pressure at the time of my final stop. Does anyone know what may be causing this?

And, a second question, I was attempting to pull a friend's vehicle out from being stuck, and during this attempt my engine light came on. It's not blinking but it's not going away either. It has been like this for 2 days now. Wasn't because of a loose gas cap. I'm going to get it to the dealer in the next couple of days but hoping it's not because of anything from attempting to tow my friend out of muddy terrain.

Wingsnut72 07-07-2013 09:18 AM

Quote:

Originally Posted by tg14226 (Post 3934664)
I have a 2013 4 door Sahara. It has only 1,200 miles on it and recently I noticed that when I apply pressure at a normal brake (stopping at faster speeds) all is good and normal. However, when I'm creeping up to a stop sign, for example, and apply pressure to the brakes there is a odd squeaky/clunky noise that only occurs, not as I'm braking but as I apply pressure at the time of my final stop. Does anyone know what may be causing this?

And, a second question, I was attempting to pull a friend's vehicle out from being stuck, and during this attempt my engine light came on. It's not blinking but it's not going away either. It has been like this for 2 days now. Wasn't because of a loose gas cap. I'm going to get it to the dealer in the next couple of days but hoping it's not because of anything from attempting to tow my friend out of muddy terrain.

My 2013 unlimited rubi has the same issue with the brakes. I've got use to the noise (almost 8,000 miles). I think it's because of crappy OE brake pads. All I know is that they shed brake dust worse that a long haired dog shedding hair on a hot day. My wheels look like crap!

iNizo 07-07-2013 10:10 AM

Re brake noise its normal. Many here have this issue.. Re engine light its not normal and you need to take it to the dealer...


All times are GMT -5. The time now is 06:44 PM.