Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   YJ Tech Forum (http://www.wranglerforum.com/f218/)
-   -   jeep losing power and backfiring intake side (http://www.wranglerforum.com/f218/jeep-losing-power-and-backfiring-intake-side-254174.html)

highjumper2009 07-07-2013 02:31 PM

jeep losing power and backfiring intake side
 
jeep starts fine drive for about 5 min and loses power and starts to back fire thru intake for about 1 min and then run ok , some time it will idle a little rough but will not stall and then starts idling ok again have check fuel pump 32pound and 39 pounds with vacum line unhooked replace about a year ago replace cat and muffler about 3 week ago o-2 4 week ago and water temp this week I first thought I had water in gas have added additive to fuel running out of idea any idea would help thanks

AllMudd 07-07-2013 02:44 PM

Year and engine?

highjumper2009 07-07-2013 08:05 PM

1991 2.5 4cyl

AllMudd 07-07-2013 08:20 PM

Have you pulled the codes to see what it's throwing? Is the Check Engine light on?

jfbilbro 07-07-2013 09:34 PM

crank position sensor

AllMudd 07-07-2013 10:26 PM

Quote:

Originally Posted by jfbilbro (Post 3937016)
crank position sensor

I would think this would make it not start. He is having trouble with it running with loss of power.

highjumper2009 07-07-2013 10:44 PM

code 12,33,52,55 code 33 ac relay no ac code 52 rich ,

Michigan jeeper 07-07-2013 10:46 PM

Fuel pump? Something to do with fuel delivery would be my guess

AllMudd 07-07-2013 10:57 PM

Could be a couple things. I would start with the heap stuff. Clean all contacts and rotor on he distributor cap. Also pull all your plugs and make sure they have strong spark and are free of debris. Then if you still have the problem with the 52 code try replacing your O2 sensor it may be throwing your ECM for a loop while its running.


All times are GMT -5. The time now is 07:00 PM.