Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   Texas Jeep Forum (http://www.wranglerforum.com/f53/)
-   -   Help needed in Forth Worth!!! (http://www.wranglerforum.com/f53/help-needed-in-forth-worth-256402.html)

brc726 07-17-2013 04:54 AM

Help needed in Forth Worth!!!
 
I went out playing in the mud yesterday in my new to me jeep, and my wires to my electric fan on my radiator melted due to laying on the engine. Now im getting no power at all, and im stuck in a bad spot. So I really need somebody that could either pull me out and tow me home less than 5 miles once I get out or somebody who is willing to help me troubleshoot out in the field as I have very limited tools due to living in a apartment and also limited knowledge about vehicles. Any help would be appreciated Brandon 972-658-4155

Design 07-17-2013 05:38 AM

Let us know a few more details like your Jeep's specifics. Model, engine, year

Other than that, a couple of things you can do. In a situation where you are just trying get a few miles I would just wire the fan directly to the battery. It will run all the time but it will prevent you overheating for the distance you need to go.

After that you can repair/replace the harness at home.

brc726 07-17-2013 06:51 AM

It's a 88 wrangler with a Chevy 305 v8. I've had the jeep for about a week but I believe the fan was already wired to the battery. The wires are melted right at the fan so I'm not sure I would be able to rewire it. But I'm not even getting any power now when I turn the key. Thanks for the advise

Design 07-17-2013 07:46 AM

A melted wire is a shorted wire. Pictures would help but almost all engine swapped vehicles are one off Frankensteins. If as you say you have minimal wrenching skills I hope you have deep pockets or great friends.

Did you melt the harness or just the wires to the fan? Have you repaired the melted/shorted section of wire? Do that first, then check all the fuses. Also verify that your battery is not simply drained.

One bite at a time work your way backwards and you can get up and running. Basic auto electric knowledge is the key.

Do you happen to know the previous owner? Did they build it? If so they might be willing to help you trouble shoot the problem.

Now don't go blaming them for your problem though. Vehicles like yours are "as is" purchases that require the afore mentioned pockets and or knowledge.

Design 07-17-2013 07:51 AM

Just re-read your last post. All auto parts stores carry aftermarket electric fans that will come with a kit to wire them up. Most importantly they usually include fuses, relays, and instructions.

Also ask them what kind of heat shielding for wiring they carry in stock (Sleaving).

brc726 07-17-2013 05:44 PM

Just put a new fan on and wired. But I'm still not getting any power. I checked the fuses under the dash and they all look to still be good. Any other suggestions?

Softheidi911 07-17-2013 06:39 PM

Where in Fort Worth?

brc726 07-17-2013 06:59 PM

Off boat club rd near Bubbas Back 40 restaurant.

CJ7nvrstk 07-18-2013 05:20 AM

I take it you got your rig off the trail, right? I'm not good with electrical but can assist with recovery if still needed.

brc726 07-18-2013 06:13 AM

No I wasn't able to find anybody to help pull it out yet. If you wouldn't mind helping pull it out and like 2 miles up the road to my apartment where I can attempt to figure out the electrical I would appreciate it. Shoot me a text 972-658-4155 if you could

CJ7nvrstk 07-18-2013 01:36 PM

Text sent


All times are GMT -5. The time now is 09:52 AM.