Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   YJ Tech Forum (http://www.wranglerforum.com/f218/)
-   -   need help! (http://www.wranglerforum.com/f218/need-help-264589.html)

g_ski 08-22-2013 11:02 AM

need help!
 
I have an 87 yj it squeaks all the time.
I took of the serpentine belt thinking was a pulley. It wasn't. then I thought that was a pilot bearing so I push the clutch and still made the noise. It squeaks more when i push the throttle. It is a 4.2.

89Saharagreen 08-22-2013 11:58 AM

it is probably your altenator or AC unit if you have one lossen the bolts that allow it to slide then take a pry bar and stretch the belt very tight hold it and tighten the bolts so it does not move. I just did this a month ago.

It may help to have someone else tighten the bolts while you hold it tight with the pry bar.

Good luck

Add belt dressing afterwards to help with the squeak.

if after that it still squeaks then your alt or AC could be going bad.

g_ski 08-22-2013 12:04 PM

I ran it without the belt on it and it was still squeaking. Do you think it could be a rocker arm?

89Saharagreen 08-22-2013 12:17 PM

Ok so where is this squeak coming from?


How long did you run it without the belt?

harleydragon 08-22-2013 12:21 PM

squeaking or squealing with the belt off sounds like it might be coming from something going on in the bell housing..that noise coming from the engine could be serious

g_ski 08-22-2013 12:45 PM

Not sure where it is coming From. I ran it for maybe one min... Could it still be the pilot bearing?

harleydragon 08-22-2013 01:00 PM

Quote:

Originally Posted by g_ski (Post 4108633)
Not sure where it is coming From. I ran it for maybe one min... Could it still be the pilot bearing?

doubtful..without hearing it in person I would say the most likely part doing the squealing would be the throwout bearing..this is the part on the clutch slave cylinder that rides against the pressure plate..if you replace it you could go ahead and replace the pilot bushing while you are in there

g_ski 08-22-2013 01:03 PM

Did that already. I will hand to take it in. Thanks fort the help

harleydragon 08-22-2013 01:12 PM

someone else might have other thoughts on what it could be..just hang around and wait for a few to see this thread...I know sometimes it is near impossible to do but if you can narrow down where it is coming from that might help

g_ski 08-22-2013 01:17 PM

It does sound like it its coming from the bell housing. Maybe the guy put the clutch and throw out bearing in wrong.

harleydragon 08-22-2013 01:22 PM

Quote:

Originally Posted by g_ski (Post 4108718)
It does sound like it its coming from the bell housing. Maybe the guy put the clutch and throw out bearing in wrong.

it sure happens and new parts can be bad sometimes


All times are GMT -5. The time now is 06:18 AM.