Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ Tech Forum (http://www.wranglerforum.com/f210/)
-   -   Power Booster (Brakes) (http://www.wranglerforum.com/f210/power-booster-brakes-268.html)

LArry200TJ 07-12-2005 01:03 PM

Power Booster (Brakes)
 
Ive found an earlier thread about this any newer info on it?

While my wife's wrangler (00) TJ was getting a relay checked at the parts store they said that the brake vacuum booster is going bad, they determined this by the idle speed and the engine rise when the brake pedle was pressed.

The ealier thread said a vacuum leak on the booster, idle control sensor, and or clean the TB passages.

amerijeep 07-12-2005 01:14 PM

OMG! There is absolutely that the 'parts store' can make that determination. I'd go with my gut instinct if I were you. It could possibly be your booster, but doesn't it seem infinetly more likely that it could be a vacuum line as you suspect?

Troubleshoot the lines. If you need help, we can help you here. I'd start just by tracing lines and looking for dry rotting and cracks. Check connections to see if they seem sevicable. The line diagram may already be posted onthis site somewhere. If not, I have it but can't get to it. My power supply went out on my home CPU. I haven't been able to locate the new PS, so I can't get to my Jeep library.

Keep us updated and let us know if you need help with it.

amerijepp

4Jeepn 07-12-2005 02:05 PM

Most likey a vacum line.. get some soap suds and gently run them over the lines.. then look for air bubbles... there is your leak. Is the jeep showing any codes?

amerijeep 07-13-2005 06:50 PM

Quote:

Originally Posted by 4Jeepn
Most likey a vacum line.. get some soap suds and gently run them over the lines.. then look for air bubbles... there is your leak.

That's good advice.


All times are GMT -5. The time now is 08:38 PM.