Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   Virginia Jeep Forum (http://www.wranglerforum.com/f74/)
-   -   Very difficult start...what is my issue? (http://www.wranglerforum.com/f74/very-difficult-start-what-is-my-issue-270249.html)

cyeag27 09-01-2013 02:09 PM

Very difficult start...what is my issue?
 
When I initially turn the key it seems like I have a dead battery. If I hold the key it slowly starts to crank and then will start if I feather the gas pedal. When I come to a stop or let it go down to idle it will stop running, again, unless I continually press the gas pedal. After a while it seems to get better and will idle. I changed all 4 oxygen sensors (Cali emissions) and put injector cleaner in my last refill. I am worried I am doing more damage but don't know where to begin. No fault codes show on my reader. Has anyone else experiences this?

Yeti6669 09-01-2013 05:57 PM

Quote:

Originally Posted by cyeag27 (Post 4194233)
When I initially turn the key it seems like I have a dead battery. If I hold the key it slowly starts to crank and then will start if I feather the gas pedal. When I come to a stop or let it go down to idle it will stop running, again, unless I continually press the gas pedal. After a while it seems to get better and will idle. I changed all 4 oxygen sensors (Cali emissions) and put injector cleaner in my last refill. I am worried I am doing more damage but don't know where to begin. No fault codes show on my reader. Has anyone else experiences this?

What octane/brand gas are you using. If I buy gas from the PX I have a similar problem but the TJ loves Shell or Liberty fuel. I also went back to 5w-30 instead of 10w-30 and it seems to be doing better with a thinner oil.

When was your last tune up/cap-rotor/ignition coil replacement?


All times are GMT -5. The time now is 07:46 PM.