Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ Tech Forum (http://www.wranglerforum.com/f210/)
-   -   Check Engine Light - Need More Help Than Other Threads Provide (http://www.wranglerforum.com/f210/check-engine-light-need-more-help-than-other-threads-provide-28557.html)

Joshpfeffer 03-31-2009 08:14 PM

Check Engine Light - Need More Help Than Other Threads Provide
 
Okay, I know the feeling everyone is going to get when they read anything resembling CEL, BUT!!!!....
My girlfriend has a 2003 Wrangler, with 4.0, manual, it's an "X"? Her Check Engine Light came on a few months ago, and I had it checked, and it was her O2 sensor. We let it go, and the light went off, and she forgot about it (as did I). Recently, it came on again and we had it checked out, and the guy didn't mention to us which code it was exactly, but he blew it off at first saying "It's just a factory code that they throw a lot". So I asked if he could reset it, and he turned back to the computer and said "Well, no, but it throws this code when it runs too cold. It has the 195 thermostat. My wife has a Jeep like this, with an automatic, and what we have to do to turn this light off is top off the antifreeze, and I put a big piece of cardboard in front of the radiator with a hole cut in the center. This gets the fluid up to the temp. sensor which is located up high, and it also lets it build up heat, which resets that light." His explanation kind of made sense as I stood there listening to him, so I came home this afternoon, changed the oil in it, topped off the antifreeze to the full mark, and started it up with the A/C on (not on recirculate, on the regular setting). I let it sit there for a while and watched the temp. rise and it made it up to 210 before leveling off and after about 5 minutes of sitting at 210, it dropped back down to what I would guess is around 195 or 200, and the light never went off. I don't know what else to do. It's obviously warming up enough that it should be warm enough for the factory standards, and it has plenty of antifreeze. Could it be the sensor? I see a sensor plugged in at the other end of the radiator hose from the radiator, and thought that maybe it's bad, but I didn't want to go swap it out until I asked on here about it. Any help anyone? I could use it. The reason I'm so worried about this is because we have to get it inspected and from what I hear, it won't pass with that light on so something needs to be done. Thanks everyone.

Joshpfeffer 03-31-2009 08:21 PM

Ok. Just checked the code with the On-Off-On-Off-On trick, and it came up with P1281, which is "Engine is Cold Too Long: Engine coolant temperature remains below normal operating temperatures during vehicle travel (Thermostat).". Does this mean that she just needs a new thermostat in it?

N39-W120 03-31-2009 08:22 PM

Quote:

Originally Posted by Joshpfeffer (Post 347212)
....
My girlfriend has a 2003 Wrangler, ....... My wife has a Jeep like this,

you're my hero... how do you pull it off??:blunt:

Actually, you can pull the computer codes yourself and look them up... 3 cycles of the key (with out starting) and they should show up in the odometer window...look it up here or one of the other "forums" and trace it down. There are many here that could help more if you had a code too...

Good luck

N39-W120 03-31-2009 08:23 PM

That helps... I would guess a thermostat stuck open

Joshpfeffer 03-31-2009 08:38 PM

Will replacing the thermostat reset this code in particular if this happens to be the issue? Or is it a code that will have to be reset by a reader?

N39-W120 03-31-2009 09:41 PM

disconnect the negative battery term for about 15 min and the computer will reset

BALLARDAdams 04-16-2009 07:25 PM

"engine cold too long." Either your thermostat is stuck in the open position or the coolant temp sensor has gone bad.
________________________________
tips: always check the spark plug wires


All times are GMT -5. The time now is 04:26 AM.