Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   YJ Tech Forum (http://www.wranglerforum.com/f218/)
-   -   NOOB to the Forums: 95 YJ 2.5L will not run past Idle (http://www.wranglerforum.com/f218/noob-to-the-forums-95-yj-2-5l-will-not-run-past-idle-29382.html)

convict27 04-19-2009 11:24 PM

NOOB to the Forums: 95 YJ 2.5L will not run past Idle
 
Hello all and thank you for allowing me access to the forum!

Ok all you gear heads, I need some help. I have an opportunity to get a 95 Jeep Wrangler 4cyl with 117,000 miles for 1000 bucks. It currently belongs to one of my ossifers and he is very trust worthy and he has listed all of the problems that he knows about with it. I have plans on making this into my megaforce vehicle for using and abusing.

The other morning when he was driving it to work for me to look over, he started it up and it seemed to be idling a little rough. He started down the street and it would only reach a certain RPM. He had no check engine lights or any other indication of a problem. Then it just died.

Today when I went over to take a look at it, It would start but ran a bit rough and seemed to be shaking quite a bit. I thought that one of the cylinders was failing to fire but when I checked each spark plug, they all were firing. We checked the airbox and the airfilter and they were clean without any blockage. I also checked the fuel pump and it was priming just fine. Does anyone else have any other suggestions?

It is not a perfect vehicle by any means, but I am mechanically inclined so having a fixer is no problem in my book. I am a little stumped though on an issue that it is having.

dooder 04-20-2009 06:02 AM

Welcome. Make certain its not misfiring before going any further. Loosen spark plug boots at plugs then start it up. carefully pull one wire off each plug one at a time. that cylinder should drop and you will notice more shaking and rpm drop. if nothing that cylinder is misfiring and you need to investigate. check the fuel filter, while the pump may prime the filter may be 99% clogged and not providing flow. if the jeep has a misfire check exhaust flow at tailpipe, cat may be clogged. good luck

jpdocdave 04-20-2009 08:34 AM

^right on, after all that possible tps problem. but dooder already gave ya where to start.

convict27 04-20-2009 08:38 AM

Thank you gents. I am going to give dooder's thoughts a try and see what comes out of it.


All times are GMT -5. The time now is 08:33 PM.