Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ Tech Forum (http://www.wranglerforum.com/f210/)
-   -   Alternator is not providing a charge (http://www.wranglerforum.com/f210/alternator-is-not-providing-a-charge-30154.html)

Beowulf 05-05-2009 10:49 AM

Alternator is not providing a charge
 
Alternator is not providing a charge

Ok, after driving down Hole in the Rock road outside of Escalante, UT the alternator is having trouble providing a charge. There are several places along the road and side roads that have huge talc pits. When you drive through them it is like hitting a sand trap filled with Flour. After several days of driving up and down this road doing some technical canyoneering the alternator started to squeal intermittently. At first we thought it was just the serpentine belt. But you upon opening the hood you could easy detect the sound was only coming from the alternator.

When the alternator was in its squeal phase the National Luna battery Monitor showed there was no juice coming from the Alternator and the power in battery fell quickly. After the squealing stopped you could see the power climb dramatically and begin to charge the battery.

Questions:

Is the alternator shot?
Can it be torn down and cleaned out?

pyro 05-05-2009 10:54 AM

u can clean it out, chances are the brushes got dirty from the fine talc and made it squeal. after it wore off it started to make contact and charge again


All times are GMT -5. The time now is 05:25 PM.